summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a83a731631a..ff7ac693ae11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
pkgname=teeworlds-git
-pkgver=0.7.start.770.g0a8ce05
+pkgver=0.7.788.g16965e4b
pkgrel=1
pkgdesc='Multiplayer 2D shooter'
arch=('i686' 'x86_64')
@@ -15,21 +15,23 @@ conflicts=('teeworlds')
source=(git+https://github.com/teeworlds/teeworlds.git
git+https://github.com/teeworlds/teeworlds-translation.git
git+https://github.com/teeworlds/teeworlds-maps.git)
-md5sums=('SKIP' 'SKIP' 'SKIP')
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
cd teeworlds
- git describe | sed 's/^v//;s/-/./g;s/_/./g;'
+ git describe | sed 's/-start//;s/-/./g'
}
prepare() {
convert "teeworlds/other/icons/Teeworlds.ico" "$srcdir/teeworlds.png"
-
+
cd teeworlds
git submodule init
git config submodule.data/languages.url "$srcdir/teeworlds-translation"
git config submodule.data/maps.url "$srcdir/teeworlds-maps"
- git submodule update
+ git submodule update
}
build() {
@@ -47,11 +49,11 @@ package() {
# Install data files
cp -r datasrc/* "$pkgdir"/usr/share/teeworlds/data
- install -m755 build/$CARCH/debug/teeworlds "$pkgdir"/usr/bin/teeworlds
- install -m755 build/$CARCH/debug/teeworlds_srv "$pkgdir"/usr/bin/teeworlds_srv
+ install -m755 build/$CARCH/debug/teeworlds "$pkgdir"/usr/bin/
+ install -m755 build/$CARCH/debug/teeworlds_srv "$pkgdir"/usr/bin/
- install -m644 license.txt "$pkgdir"/usr/share/licenses/teeworlds/
- install -m644 other/teeworlds.appdata.xml "$pkgdir"/usr/share/appdata/
- install -m644 other/teeworlds.desktop "$pkgdir"/usr/share/applications/
- install -m644 ../teeworlds-0.png "$pkgdir"/usr/share/pixmaps/teeworlds.png
+ install -m644 license.txt "$pkgdir/usr/share/licenses/teeworlds/"
+ install -m644 other/teeworlds.appdata.xml "$pkgdir/usr/share/appdata/"
+ install -m644 other/teeworlds.desktop "$pkgdir/usr/share/applications/"
+ install -m644 ../teeworlds-0.png "$pkgdir/usr/share/pixmaps/teeworlds.png"
}