summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 23 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a86bbecdff61..eaa37a004a9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,10 +5,9 @@
#
# If you want to cherry-pick patches, check out the git repo:
# TODO: Allow selection of patches in PKGBUILD.
-
pkgname=telegram-desktop-patched
-pkgver=0.9.19
-pkgrel=3
+pkgver=0.9.33
+pkgrel=1
_qtver=5.5.1
pkgdesc='Telegram Desktop with bigger sticker panel and dark colour scheme patches.'
arch=('i686' 'x86_64')
@@ -20,13 +19,17 @@ depends=('ffmpeg' 'icu' 'jasper' 'libexif' 'libmng' 'libwebp' 'libxkbcommon-x11'
makedepends=('git' 'patch' 'libunity' 'libappindicator-gtk2')
provides=('telegram-desktop')
conflicts=('telegram-desktop')
-source=("tdesktop::git+https://git.mel.vin/melvin/telegram-desktop.git#branch=release"
- "http://download.qt-project.org/official_releases/qt/${_qtver%.*}/$_qtver/single/qt-everywhere-opensource-src-$_qtver.tar.xz"
+source=("tdesktop::git+https://git.mel.vin/melvin/telegram-desktop.git#tag=v0.9.33-1"
+ "http://download.qt.io/official_releases/qt/${_qtver%.*}/$_qtver/single/qt-everywhere-opensource-src-$_qtver.tar.xz"
+ "breakpad::git+https://chromium.googlesource.com/breakpad/breakpad"
+ "breakpad-lss::git+https://chromium.googlesource.com/linux-syscall-support"
"telegramdesktop.desktop"
"tg.protocol")
sha256sums=('SKIP'
'6f028e63d4992be2b4a5526f2ef3bfa2fe28c5c757554b11d9e8d86189652518'
- '0e936f964fbaa7392a0c58aa919d6ea8c5f931472e1ab59b437523aa1a1d585c'
+ 'SKIP'
+ 'SKIP'
+ 'adb111ad10872e2858c8ccdd8645a1566736dec8d48deb50a9a7c0fbcae5cfb0'
'd4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb')
install="$pkgname.install"
@@ -34,17 +37,24 @@ install="$pkgname.install"
prepare() {
cd "$srcdir/tdesktop"
+ mkdir -p "$srcdir/Libraries"
+
local qt_patch_file="$srcdir/tdesktop/Telegram/_qtbase_${_qtver//./_}_patch.diff"
if [ "$qt_patch_file" -nt "$srcdir/Libraries/QtStatic" ]; then
- mkdir -p "$srcdir/Libraries"
rm -rf "$srcdir/Libraries/QtStatic"
mv "$srcdir/qt-everywhere-opensource-src-$_qtver" "$srcdir/Libraries/QtStatic"
cd "$srcdir/Libraries/QtStatic/qtbase"
patch -p1 -i "$qt_patch_file"
fi
+ if [ ! -h "$srcdir/Libraries/breakpad" ]; then
+ ln -s "$srcdir/breakpad" "$srcdir/Libraries/breakpad"
+ ln -s "$srcdir/breakpad-lss" "$srcdir/Libraries/breakpad/src/third_party/lss"
+ fi
+
sed -i 's/CUSTOM_API_ID//g' "$srcdir/tdesktop/Telegram/Telegram.pro"
sed -i 's,LIBS += /usr/local/lib/libxkbcommon.a,,g' "$srcdir/tdesktop/Telegram/Telegram.pro"
+ sed -i 's,LIBS += /usr/local/lib/libz.a,LIBS += -lz,g' "$srcdir/tdesktop/Telegram/Telegram.pro"
(
echo "DEFINES += TDESKTOP_DISABLE_AUTOUPDATE"
@@ -52,6 +62,7 @@ prepare() {
echo 'INCLUDEPATH += "/usr/lib/glib-2.0/include"'
echo 'INCLUDEPATH += "/usr/lib/gtk-2.0/include"'
echo 'INCLUDEPATH += "/usr/include/opus"'
+ echo 'LIBS += -lcrypto -lssl'
) >> "$srcdir/tdesktop/Telegram/Telegram.pro"
}
@@ -66,6 +77,11 @@ build() {
export PATH="$srcdir/qt/bin:$PATH"
+ # Build breakpad
+ cd "$srcdir/Libraries/breakpad"
+ ./configure
+ make
+
# Build MetaStyle
mkdir -p "$srcdir/tdesktop/Linux/DebugIntermediateStyle"
cd "$srcdir/tdesktop/Linux/DebugIntermediateStyle"