summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 12 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c01fcd5a7bee..e4d7f12315c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
-# Maintainer: Francisco Demartino <demartino.francisco@gmail.com>
+# Maintainer: farwayer <farwayer@gmail.com>
+# Submitter: Francisco Demartino <demartino.francisco@gmail.com>
+_ver=1.4.0
_pkgname=telegram-purple
pkgname=${_pkgname}-git
-pkgver=v1.2.5.r0.gdf29bbc
+pkgver=1.4.0.ceec1a9
pkgrel=1
pkgdesc="Adds support for Telegram to Pidgin, Adium, Finch and other Libpurple based messengers."
arch=('i686' 'x86_64')
url="https://github.com/majn/telegram-purple"
license=("GPL")
makedepends=("git")
-depends=('glib2' 'libgcrypt' 'libpurple' 'zlib' 'libwebp')
-conflict=('telegram-purple')
+depends=('libpurple' 'libwebp')
+conflicts=('telegram-purple')
+provides=('telegram-purple')
-source=("git+https://github.com/majn/telegram-purple")
+source=("git+https://github.com/majn/telegram-purple#branch=dev-${_ver}")
sha512sums=('SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
- git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ printf "${_ver}.%s" "$(git rev-parse --short HEAD)"
}
prepare() {
@@ -27,21 +30,12 @@ prepare() {
build() {
cd "${srcdir}/${_pkgname}"
-
- ./configure
-
- # keep this part synced with the Makefile
- PLUGIN_DIR_PURPLE=$(pkg-config --variable=plugindir purple)
- DATA_ROOT_DIR_PURPLE=$(pkg-config --variable=datarootdir purple)
- PIDGIN_PROTOCOLS_PIXMAPS_DIR=${DESTDIR}${DATA_ROOT_DIR_PURPLE}/pixmaps/pidgin/protocols
- mkdir -p ${DESTDIR}${PLUGIN_DIR_PURPLE}
- mkdir -p ${PIDGIN_PROTOCOLS_PIXMAPS_DIR}
- mkdir -p ${PIDGIN_PROTOCOLS_PIXMAPS_DIR}/{16,22,48}
-
+ ./configure --prefix=/usr
make
}
package() {
cd "${srcdir}/${_pkgname}"
- make DESTDIR="$pkgdir/" install
+ make DESTDIR="${pkgdir}/" install
+ rmdir -p --ignore-fail-on-non-empty "${pkgdir}/etc/${_pkgname}"
}