summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5cf5ac43842
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: JKA Network (JoseluCross, Kprkpr, Yukialba) <contacto@jkanetwork.com>
+pkgname=telepad
+pkgver=1.0.7
+pkgrel=1
+pkgdesc="Telepad desktop application. This software communicates with the Telepad mobile application in order to use a mobile/tablet as a remote mouse and keyboard."
+arch=('x86_64' 'i686')
+url="https://archlinuxarm.org/wiki/Distcc_Cross-Compiling"
+license=('custom')
+provides=('telepad' 'telepad-app')
+depends=('bluez-libs' 'libx11' 'libxext' 'libxtst' 'jre8-openjdk')
+options=(!emptydirs)
+source=("https://launchpad.net/~pelle-vincent-n/+archive/ubuntu/telepad-ppa/+files/${pkgname}_${pkgver}.orig.tar.xz")
+md5sums=('9bd69e4f4757ff61683d17da044c2453')
+build() {
+ cd "${pkgname}-${pkgver}.orig"
+ ./configure
+ make
+}
+package() {
+ cd "${pkgname}-${pkgver}.orig"
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 debian/copyright "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}