summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9d2d3e64945d..108c07db0306 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Upstream URL: https://github.com/tensorflow/tensorflow
pkgname=tensorflow-git
-pkgver=0.5.0.r10.gb4629c0
+pkgver=0.5.0.r14.g1d76583
pkgrel=1
pkgdesc="Open source software library for numerical computation using data flow graphs."
arch=('i686' 'x86_64')
@@ -11,11 +11,10 @@ license=('Apache2')
provides=('tensorflow')
conflicts=('tensorflow' 'python2-tensorflow')
depends=('python2-numpy' 'swig' 'python2-wheel')
-makedepends=('git' 'python2-pip')
+makedepends=('git' 'python2-pip' 'bazel')
source=("git+https://github.com/tensorflow/tensorflow"
- "git+https://github.com/google/protobuf"
- "git+https://github.com/bazelbuild/bazel")
-md5sums=('SKIP' 'SKIP' 'SKIP')
+ "git+https://github.com/google/protobuf")
+md5sums=('SKIP' 'SKIP')
pkgver() {
cd "$srcdir/tensorflow"
@@ -35,18 +34,13 @@ prepare() {
}
build() {
- # Build bazel
- echo "Please note: currently, bazel version 0.1.0 is required to build this package. Building it temporarily..."
- cd "$srcdir/bazel"
- git checkout tags/0.1.0
- ./compile.sh
- export TMP_BAZEL_EXECUTABLE=`pwd`/output/bazel
+ echo "Make sure your .bazelrc points to the correct workspace, e.g. %workspace%:/opt/bazel/base_workspace."
# Build tensorflow
cd "$srcdir/tensorflow"
./configure
- ${TMP_BAZEL_EXECUTABLE} build --jobs 2 -c opt //tensorflow/tools/pip_package:build_pip_package
+ bazel build --jobs 2 -c opt //tensorflow/tools/pip_package:build_pip_package
sed -i 's/python/python2/g' bazel-bin/tensorflow/tools/pip_package/build_pip_package
bazel-bin/tensorflow/tools/pip_package/build_pip_package $srcdir/tmp
@@ -56,6 +50,6 @@ package() {
cd "$srcdir/tensorflow"
TMP_PKG=`find $srcdir/tmp -name "tensor*.whl"`
- pip2 install --root $pkgdir/ $TMP_PKG --no-dependencies
+ pip2 install --upgrade --root $pkgdir/ $TMP_PKG --no-dependencies
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}