summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d16c5925e82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jack O'Sullivan <jackos1998 at gmail dot com>
+pkgname=terminal-mines
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="An ncurses-based minesweeper game."
+url='https://github.com/accatyyc/terminal-mines'
+license=("custom:Unknown")
+arch=('i686' 'x86_64')
+source=("git+https://github.com/accatyyc/terminal-mines#tag=$pkgver")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$pkgname"
+ git submodule init
+ git submodule update
+}
+build() {
+ cd "$pkgname"
+ make
+}
+package() {
+ cd "$pkgname"
+ make INSTALL_PATH="$pkgdir/usr" install
+}