summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 92d088d32b96..f58e509fbc76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,27 @@
-# Maintainer:
+# Maintainer: James Smith <jslonescout AT icloud DOT com>
# Contributor: Thomas Ascher <thomas.ascher@gmx.at>
+_pkgname=Terminal
pkgname=terminal.app
-pkgrel=1
+pkgrel=2
pkgver=0.9.9
pkgdesc='A terminal emulator for GNUstep'
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'armv7h')
url='http://www.nongnu.org/gap/terminal/index.html'
license=('GPL2')
-groups=('gnustep')
-depends=('gnustep-base' 'gnustep-gui' 'gnustep-back')
+groups=('gnustep-apps')
+depends=('gnustep-base' 'gnustep-gui')
makedepends=('gcc-objc')
source=("https://savannah.nongnu.org/download/gap/Terminal-$pkgver.tar.gz")
sha256sums=('27f81bbecdbd10cde8c080012cde4973bec20e551c58c29f353733cf03c220e9')
build() {
- cd Terminal-$pkgver
+ cd "$_pkgname-$pkgver"
make
}
package() {
- cd Terminal-$pkgver
+ cd "$_pkgname-$pkgver"
make DESTDIR="$pkgdir" install
- install -d "$pkgdir"/usr/share/applications
- ln -s /usr/lib/GNUstep/Applications/Terminal.app/Resources/Terminal.desktop \
- "$pkgdir"/usr/share/applications/Terminal.desktop
+ install -Dm644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
}