summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f1c1ca20056
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Elijah Gregg <lovetocode999@ctrl-c.club>
+pkgname=termpdf.py-git
+pkgver=r0.gf697237
+pkgrel=1
+pkgdesc="A graphical pdf (and epub, cbz, ...) reader that works inside the kitty terminal"
+arch=("x86_64")
+url="https://github.com/dsanson/termpdf.py"
+license=("MIT")
+makedepends=("python-setuptools")
+depends=("python" "python-pymupdf" "python-pdfrw" "python-pyperclip"
+ "python-pybtex" "python-pynvim" "python-roman" "python-pagelabels")
+provides=("termpdf.py")
+conflicts=("termpdf.py")
+source=("git+https://github.com/dsanson/termpdf.py.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/termpdf.py"
+
+ printf 'r%s.g%s' "$(git rev-list "$_tag"..HEAD --count)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/termpdf.py"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/termpdf.py"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}