summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e16b9c253b62..fdb39e927d1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainers: Mike Cooper <mythmon at elem.us>, Mikko <mikko at 5x.fi>
pkgname=terraria-server
-pkgver=1.4.1.2
-pkgrel=30
+pkgver=1.4.2.1
+pkgrel=31
pkgdesc="Official dedicated server for Terraria"
arch=('x86_64' 'x86')
license=('unknown')
@@ -17,14 +17,14 @@ _pkgver=$(echo $pkgver | sed 's/\.//g')
# "http://terraria.org/server/${pkgname}-${_pkgver}.zip"
# https://terraria.org/server/ links after 1402 give a 404, so we use the archive link instead.
-source=("https://terraria.org/system/dedicated_servers/archives/000/000/042/original/terraria-server-1412.zip"
- "https://github.com/mono/reference-assemblies/blob/master/v4.8/System.dll?raw=true"
- "https://github.com/mono/reference-assemblies/blob/master/v4.8/System.Core.dll?raw=true"
+source=("https://terraria.org/system/dedicated_servers/archives/000/000/044/original/terraria-server-1421.zip"
+ "https://github.com/mono/reference-assemblies/raw/main/v4.8/System.dll"
+ "https://github.com/mono/reference-assemblies/raw/main/v4.8/System.Core.dll"
'terraria-server'
'config.txt'
'terraria-server@.service')
-sha256sums=('10e6a806e121abb31f3cf46731a6b7e37544d247ea656320b8deffe8e4f10ca2'
+sha256sums=('19f27c37b9c52b56ed51e387a1b252e3eaeb7a1fc8e802218ab7186c5057cb40'
'6906a72d0c320697cac46820740fd67976e0b270378a772ea42968c463a2b8e5'
'b06c0c07ffd912013cc35987d05ce9e6415cc04882b4b9b5c8ebf8a65fbea556'
'fba253786b8668dabd18b03514b24b3aac9b24ed9a74dfdacee35f41659c30c9'
@@ -35,8 +35,8 @@ package() {
unzip -o "${pkgname}-${_pkgver}.zip"
# Copy the updated dlls to /Linux so that they work with Mono 5.x
- cp -rv "System.dll?raw=true" "${_pkgver}/Linux/System.dll";
- cp -rv "System.Core.dll?raw=true" "${_pkgver}/Linux/System.Core.dll";
+ cp -rv "System.dll" "${_pkgver}/Linux/System.dll";
+ cp -rv "System.Core.dll" "${_pkgver}/Linux/System.Core.dll";
cd "${_pkgver}/Linux"
dest="${pkgdir}/opt/terraria-server"