summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 26 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 871fc8e472b6..7609cf7c8092 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Butui Hu <hot123tea123@gmail.com>
pkgname=texlive-full
-pkgver=2022.20220406
+pkgver=2022.20221030
pkgrel=1
epoch=1
pkgdesc="This packages provides texlive-full in /opt. It also tricks ArchLinux into thinking it has its texlive packages installed."
@@ -11,17 +11,20 @@ arch=("x86_64")
license=('custom')
makedepends=('rsync')
depends=('libxcrypt-compat')
-provides=('asymptote' 'git-latexdiff' 'haskell-citeproc' 'psutils' 't1utils'
-'texlive-bibtexextra' 'texlive-bin' 'texlive-core' 'texlive-fontsextra'
-'texlive-formatsextra' 'texlive-games' 'texlive-humanities' 'texlive-latexextra'
-'texlive-music' 'texlive-pictures' 'texlive-pstricks' 'texlive-publishers'
-'texlive-science' 'texlive-langchinese' 'texlive-langcyrillic' 'texlive-langextra'
+provides=('asymptote' 'git-latexdiff' 'psutils' 't1utils'
+'texlive-bin' 'texlive-most'
+# texlive-most contains
+# 'texlive-bibtexextra' 'texlive-core' 'texlive-fontsextra'
+# 'texlive-formatsextra' 'texlive-games' 'texlive-humanities' 'texlive-latexextra'
+# 'texlive-music' 'texlive-pictures' 'texlive-pstricks' 'texlive-publishers'
+# 'texlive-science'
+#
+# 'haskell-citeproc' is not provided, only citeproc-lua is provided.
+'texlive-langchinese' 'texlive-langcyrillic' 'texlive-langextra'
'texlive-langgreek' 'texlive-langjapanese' 'texlive-langkorean' 'texlive-htmlxml')
conflicts=('asymptote' 'git-latexdiff' 'haskell-citeproc' 'psutils' 't1utils'
-'texlive-bibtexextra' 'texlive-bin' 'texlive-core' 'texlive-fontsextra'
-'texlive-formatsextra' 'texlive-games' 'texlive-humanities' 'texlive-latexextra'
-'texlive-music' 'texlive-pictures' 'texlive-pstricks' 'texlive-publishers'
-'texlive-science' 'texlive-langchinese' 'texlive-langcyrillic' 'texlive-langextra'
+'texlive-bin' 'texlive-most'
+'texlive-langchinese' 'texlive-langcyrillic' 'texlive-langextra'
'texlive-langgreek' 'texlive-langjapanese' 'texlive-langkorean' 'texlive-htmlxml'
)
source=("install-tl-unx-${pkgver}.tar.gz::https://mirror.ctan.org/systems/texlive/tlnet/install-tl-unx.tar.gz"
@@ -33,21 +36,21 @@ options=(!strip)
# You can choose a mirror and rsync directory here.
# _syncdir works as a local CTAN mirror (about 4.5GiB) for faster installation
-# For mainland China, use
+# For mainland China, use
# mirrors.bfsu.edu.cn/CTAN/systems/texlive/tlnet/
_mirror='rsync.dante.ctan.org/CTAN/systems/texlive/tlnet/'
_syncdir="CTAN/tlnet"
pkgver(){
- _tldate=$(ls | grep -E '[0-9]+' -o | sort -r | head -1)
- _year=$(cat ${srcdir}/install-tl-${_tldate}/release-texlive.txt| grep -E '[0-9]+' -o)
+ local _tldate=$(ls | grep -E '[0-9]+' -o | sort -r | head -1)
+ local _year=$(cat ${srcdir}/install-tl-${_tldate}/release-texlive.txt| grep -E '[0-9]+' -o)
echo "${_year}.${_tldate}"
}
prepare(){
# TeXLive release year
- _tldate=$(ls | grep -E '[0-9]+' -o | sort -r | head -1)
- _year=$(cat ${srcdir}/install-tl-${_tldate}/release-texlive.txt| grep -E '[0-9]+' -o)
+ local _tldate=$(ls | grep -E '[0-9]+' -o | sort -r | head -1)
+ local _year=$(cat ${srcdir}/install-tl-${_tldate}/release-texlive.txt| grep -E '[0-9]+' -o)
# creating a profile for unattened installation
echo "selected_scheme scheme-full" > "${srcdir}/texlive.profile"
echo "TEXDIR ${pkgdir}/opt/texlive/${_year}" >> "${srcdir}/texlive.profile"
@@ -66,13 +69,13 @@ prepare(){
}
package() {
- _tldate=$(ls | grep -E '[0-9]+' -o | sort -r | head -1)
- _year=$(cat ${srcdir}/install-tl-${_tldate}/release-texlive.txt| grep -E '[0-9]+' -o)
+ local _tldate=$(ls | grep -E '[0-9]+' -o | sort -r | head -1)
+ local _year=$(cat ${srcdir}/install-tl-${_tldate}/release-texlive.txt| grep -E '[0-9]+' -o)
# find installer path automatically.
- _installer_dir=install-tl-${_tldate}
+ local _installer_dir=install-tl-${_tldate}
# start the installer and install
- _timestamp=$(date "+%m%d%H%M")
+ local _timestamp=$(date "+%m%d%H%M")
"${srcdir}/${_installer_dir}/install-tl" \
-profile "${srcdir}/texlive.profile" -repository ${_syncdir} -logfile "/tmp/install-tl-${_timestamp}.log"
@@ -85,10 +88,10 @@ package() {
msg2 "Linking manpage"
mkdir -p ${pkgdir}/usr/share/man/{man1,man5}
for mann in {man1,man5}
- do
+ do
cd ${pkgdir}/opt/texlive/${_year}/texmf-dist/doc/man/$mann
find . -type f,l -print0 |sed "s|\./||g"| while read -d $'\0' man
- do
+ do
ln -s "/opt/texlive/${_year}/texmf-dist/doc/man/$mann/${man}" "${pkgdir}/usr/share/man/$mann/"
done
done
@@ -97,7 +100,7 @@ package() {
cd ${pkgdir}/opt/texlive/${_year}/texmf-dist/doc/info/
mkdir -p ${pkgdir}/usr/share/info
find . -type f,l -print0 |sed "s|\./||g"| while read -d $'\0' info
- do
+ do
ln -s "/opt/texlive/${_year}/texmf-dist/doc/info/${info}" "${pkgdir}/usr/share/info/"
done
@@ -105,7 +108,7 @@ package() {
cd ${pkgdir}/opt/texlive/${_year}/bin/${arch}-linux/
mkdir -p ${pkgdir}/usr/bin
find . -type f,l -print0 |sed "s|\./||g"| while read -d $'\0' bin
- do
+ do
ln -s "/opt/texlive/${_year}/bin/${arch}-linux/${bin}" "${pkgdir}/usr/bin/"
done