summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8a46840f13a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Yichao Zhou <broken.zhou@gmail.com>
+pkgname=texlive-installer
+pkgver=2018
+pkgrel=0
+pkgdesc="This packages provides the installer of texlive. It also tricks Arch into thinking it has its texlive packages installed."
+url="http://www.tug.org/texlive/"
+arch=('any')
+license=('GPL')
+depends=('wget' 'xz')
+optdepends=()
+makedepends=()
+replaces=()
+conflicts=('texlive-bin' $(pacman -Sgq texlive-most texlive-lang))
+provides=('texlive-bin' $(pacman -Sgq texlive-most texlive-lang))
+source=("http://mirror.ctan.org/systems/texlive/tlnet/install-tl-unx.tar.gz")
+md5sums=('SKIP')
+install=${pkgname}.install
+
+package() {
+ rm -r ${srcdir}/install-tl-[0-9]*/tlpkg/installer/wget
+ rm -r ${srcdir}/install-tl-[0-9]*/tlpkg/installer/xz
+
+ install -d "$pkgdir"/opt
+ cp -R ${srcdir}/install-tl-[0-9]*/ "$pkgdir"/opt/texlive-installer
+}