summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ce3d3e02b07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: graysky <graysky AT archlinux DOT us>
+
+pkgname=texturecache
+_pkgname=texturecache.py
+pkgver=1.9.4
+pkgrel=1
+pkgdesc="Utility to manage the XBMC/Kodi texture cache and more."
+arch=('any')
+url="https://github.com/MilhouseVH/texturecache.py"
+license=('GPL')
+depends=('python' 'kodi')
+conflicts=('xbmc-texturecache')
+replaces=('xbmc-texturecache')
+install=readme.install
+source=("https://github.com/MilhouseVH/${_pkgname/%%.py}/archive/$pkgver.tar.gz")
+sha256sums=('13ec361d76de07996dfb5bdd16282eb36e6b2e8ae05e5e1fe928bd58b2e62f8d')
+
+package() {
+ cd "$_pkgname-$pkgver"
+ install -Dm755 "$_pkgname" "$pkgdir/usr/bin/texturecache"
+ install -Dm644 "texturecache.cfg.defaults" "$pkgdir/usr/share/texturecache/texturecache.cfg"
+}