summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6043203d46bf..77cbe1234841 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Antti Juhani Oja <antti.oja@gmail.com>
pkgname=texturepacker
-pkgver=4.4.0
+pkgver=4.6.1
pkgrel=1
pkgdesc="Sprite sheet creator and image optimizer"
arch=('x86_64')
@@ -16,7 +16,7 @@ depends=('shared-mime-info' 'hicolor-icon-theme' 'desktop-file-utils' 'grantlee-
'gcc-libs-multilib' 'qt5-svg' 'qt5-declarative' 'qt5-imageformats'
'qt5-quickcontrols')
source=("http://www.codeandweb.com/download/$pkgname/${pkgver}/TexturePacker-${pkgver}-ubuntu64.deb")
-sha256sums=("65d278eb75575315c54adef6db1ab2bd4b2f19f3be7dfc7736a32b7bfd248c90")
+sha256sums=("c891db802489fdebcce55ae55d6f1418c5d794fff4a86bed7bfdc5dd21827edf")
build() {
@@ -32,15 +32,18 @@ package() {
# Enter $pkgdir.
cd ${pkgdir}/usr/lib/$pkgname/
+ # IMPORTANT NOTE: It looks like codeandweb stopped compiling with the -fPIC
+ # flag. We must keep the bloat for now.
+
# Delete all the extra lib folders.
- rm -rf generic/ grantlee/ iconengines/ imageformats/ platforminputcontexts/ platforms/ \
- QtGraphicalEffects/ QtQml/ QtQuick/ QtQuick.2/ xcbglintegrations/
+ #rm -rf generic/ grantlee/ iconengines/ imageformats/ platforminputcontexts/ platforms/ \
+ # QtGraphicalEffects/ QtQml/ QtQuick/ QtQuick.2/ xcbglintegrations/
# Delete the useless lib files.
- rm -rf libGrantlee* libicudata* libicui18n* libicuuc* libQt5*
+ #rm -rf libGrantlee* libicudata* libicui18n* libicuuc* libQt5*
# Get rid of the Qt configuration that messes up LD_LIBRARY_PATH.
- rm -rf qt.conf
+ #rm -rf qt.conf
install -Dm644 "${pkgdir}/usr/share/$pkgname/documents/LicenseAgreement.txt" \
"${pkgdir}/usr/share/licenses/${pkgname}/LicenseAgreement.txt"