summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22246a186581
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Thanos Apostolou <thanosapostolou@outlook.com>
+pkgname=thapo-calc
+pkgver=0.2
+pkgrel=1
+pkgdesc="ThApo-Calc (Thanos Apostolou' Calculator) is a simple calculator written in c++"
+arch=('x86_64')
+url="https://gitlab.com/ThanosApostolou/thapo-calc"
+license=('GPL3')
+source=("https://gitlab.com/ThanosApostolou/thapo-calc/-/archive/0.2/thapo-calc-0.2.tar.gz")
+md5sums=('538d580e92fa92f694e793e72b509a73')
+
+build() {
+ cd "$pkgname-$pkgver"
+ arch-meson builddir
+ ninja -C builddir
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ DESTDIR="$pkgdir/" ninja -C builddir install
+}