summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83c5d3b9986f..b226463c2012 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Victor Tran <vicr12345 at gmail dot com>
pkgname=thefile
-pkgver=4.0.1
+pkgver=4.0.2
pkgrel=0
pkgdesc="File Manager"
arch=("x86_64")
url="https://github.com/vicr123/thefile"
license=('GPL3')
depends=('xdg-utils' 'qt5-base' 'the-libs' 'libtdesktopenvironment' 'libthefrisbee' 'qt5-svg')
-makedepends=('qt5-tools')
-source=("$pkgname-$pkgver"::"https://github.com/vicr123/thefile/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('f8184a2ce92d5be72af15b5a09e6c8f1e2f0bc240751afb6d267917374fc36f8')
+makedepends=('git' 'qt5-tools')
+source=("git+https://github.com/vicr123/thefile#tag=v$pkgver")
+sha256sums=('SKIP')
build() {
- cd "thefile-$pkgver"
+ cd thefile
mkdir -p build
cd build
qmake ../theFile.pro
@@ -20,7 +20,6 @@ build() {
}
package() {
- cd "thefile-$pkgver"
- cd build
+ cd thefile/build
make install INSTALL_ROOT=$pkgdir
}