summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37774c18f97b..4820c5223d07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,16 +8,19 @@ arch=('any')
url="https://github.com/laramies/theHarvester"
license=('GPL2')
depends=(
- 'bash'
- 'python'
- 'python-yaml'
- 'python-requests'
- 'python-plotly'
- 'python-pytest'
- 'python-texttable'
- 'python-shodan'
- 'python-beautifulsoup4'
- 'python-decorator')
+ 'bash'
+ 'python'
+ 'python-yaml'
+ 'python-requests'
+ 'python-plotly'
+ 'python-pytest'
+ 'python-texttable'
+ 'python-shodan'
+ 'python-beautifulsoup4'
+ 'python-yaml'
+ 'python-decorator'
+ 'python-censys'
+)
makedepends=('git' 'bash')
provides=("${pkgname}")
conflicts=("${pkgname}")
@@ -52,3 +55,8 @@ package() {
ln -s "/opt/$pkgname/run.sh" "$pkgdir/usr/bin/theharvester"
}
+
+check(){
+ cd "${srcdir}"
+ pytest
+}