summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index acb0bc2c98f3..9a5703b2bb18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,10 +35,13 @@ build() {
package() {
# Create directory
install -dm 755 "$pkgdir"/usr/lib/$pkgname
- # Source code
+
+ # Source code (symlinks are not dereferenced)
cp -r --no-preserve=ownership --preserve=mode \
- src-gen lib package.json node_modules \
+ src-gen lib node_modules \
"$pkgdir/usr/lib/$pkgname/"
+ # package.json (should be dereferenced)
+ install -Dm644 package.json "$pkgdir/usr/lib/$pkgname/"
# Executable
install -Dm755 theia-electron "$pkgdir/usr/bin/$pkgname"