summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 17 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6ce5ad5b6c28..aa3934952c7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=theme-hospital-gog
-pkgver=2.0.0.5
+pkgver=2.1.0.8
pkgrel=1
pkgdesc="Manage a hospital in this humoristic business simulation game (gog.com version)"
-url="http://gog.com"
+url="http://gog.com/game/theme_hospital"
license=('custom: commercial')
arch=('any')
makedepends=('innoextract' 'icoutils')
@@ -12,33 +12,36 @@ depends=('bash')
optdepends=('corsix-th: to play it natively'
'dosbox=0.74: to play with the original executable')
install=$pkgname.install
-# You need to download the gog.com installer file manually or with lgogdownloader.
-# Or you can configure DLAGENTS in makepkg.conf to auto-search through a directory
-# containing gog.com downloads:
-# DLAGENTS=('gog::/usr/bin/find /path/to/downloads -name $(echo %u | cut -c 7-) -exec ln -s \{\} %o \; -quit')
-DLAGENTS+=('gog::/usr/bin/echo "Could not find \"$(echo %u | cut -c 7-)\". Manually download it to \"$(pwd)\", or set up a gog:// DLAGENT."; exit 1')
-source=("gog://setup_theme_hospital_$pkgver.exe"
+source=("setup_theme_hospital_$pkgver.exe"::"gogdownloader://theme_hospital/installer_win_en"
"$pkgname.desktop"
"$pkgname.sh")
-sha256sums=('c41a77632ca1c33389b57d7210936eb5151ceb6d540707420a4de2d55bd47497'
+sha256sums=('8e4f35ca9751866f48a81cd53c54aeed85e1fb5f9212339b2a3e849a0022df65'
'22b24005cc952ae0a7ff92a63c9791567206ebde58740ebc66dfad65060a39b5'
'e47f1ce9b24d1154d0748bbbefdc2a9979f90ff051404f666897968ec7d5c5aa')
PKGEXT=".pkg.tar"
+# You need to download the gog.com installer file to this directory ($PWD),
+# either manually or with lgogdownloader. You can also configure DLAGENTS in
+# makepkg.conf to auto-download.
+#
+# The following is just a fallback to the above to notify the user:
+DLAGENTS+=('gogdownloader::/usr/bin/awk BEGIN{print"Please\ download\ the\ file\ \\""\ substr("%o",1,length("%o")-5)\ "\\"\ manually\\nor\ setup\ a\ gogdownloader://\ DLAGENT\ in\ makepkg.conf!\ Read\ this\ PKGBUILD\ for\ more\ information.";exit\ 1}')
+
prepare() {
# extract installer (convert files to lowercase, as DOS does not care)
innoextract -e -L -d "$srcdir" setup_theme_hospital_${pkgver}.exe
# convert icon
- icotool -x app/gfw_high.ico
+ icotool -x app/goggame-1207659026.ico
# create launchers
for _m in client server settings; do
sed "s|Exec=theme-hospital|&-$_m|;s|Name=Theme Hospital|& (${_m^})|" \
$pkgname.desktop > theme-hospital-$_m.desktop
done
- # remove bundled dosbox and windows stuff
- rm -rf app/dosbox app/*.ico app/*.dll
+ cd app
+ # remove bundled dosbox, windows stuff and gog client files
+ rm -rf dosbox/ *.ico *.dll goggame-1207659026.* *.zip __support
# fix mount directory
- sed 's|mount C ..|mount C .|' -i app/dosbox*.conf
+ sed 's|mount C "\.\."|mount C "."|' -i dosboxth*.conf
}
package() {
@@ -60,5 +63,5 @@ package() {
install -m644 theme-hospital-$_m.desktop "$pkgdir"/usr/share/applications
done
# icon
- install -Dm644 gfw_high_7_48x48x32.png "$pkgdir"/usr/share/pixmaps/theme-hospital.png
+ install -Dm644 goggame-1207659026_7_48x48x32.png "$pkgdir"/usr/share/pixmaps/theme-hospital.png
}