summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD106
1 files changed, 69 insertions, 37 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 166fddb16723..d4320c5b7235 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,87 @@
-# Maintainer: detrito <detrito@inventati.org>
-# Contributor: Thomas Holder <thomas@thomas-holder.de>
-# Contributor: detrito <detrito@inventati.org>
-
-pkgname=therion
-pkgver=5.4.1
-pkgrel=2
-pkgdesc="A cave surveying software"
+# Maintainer: Thomas Holder <thomas at thomas-holder dot de>
+# Contributor: detrito <detrito at inventati dot org>
+# Contributor: Rodrigo Severo <rsev at protonmail dot com>
+
+pkgname='therion'
+pkgver='6.2.1'
+pkgrel='1'
+pkgdesc="Cave surveying: processes survey data and generates maps or 3D models of caves"
arch=('x86_64' 'i686')
url="http://therion.speleo.sk"
license=('GPL2')
+changelog='CHANGELOG'
-# avoid parallel-execution errors
-MAKEFLAGS="-j1"
-
-depends=('tk' 'bwidget' 'texlive-core' 'imagemagick' 'wxgtk' 'glu' 'vtk'
- 'webkitgtk2')
+depends=(
+ 'bwidget'
+ 'fmt'
+ 'freetype2'
+ 'glu'
+ 'imagemagick'
+ 'libjpeg-turbo'
+ 'libpng'
+ 'python'
+ 'shapelib'
+ 'texlive-core'
+ 'texlive-metapost'
+ 'tk'
+ 'tkimg'
+ 'vtk'
+ 'wxwidgets-gtk3'
+ 'zlib'
+)
-optdepends=('libjpeg-turbo' 'libpng' 'zlib')
+makedepends=(
+ 'catch2'
+ 'cmake'
+ 'perl'
+)
-source=("http://github.com/therion/therion/archive/v${pkgver}.tar.gz"
- "loch_vtk7.patch"
- "make_install.patch"
- "therion_ini.patch")
+source=(
+ "http://github.com/therion/therion/archive/v${pkgver}.tar.gz"
+ 'therion_ini.patch'
+)
-sha256sums=('6e4b88d1803bdf252cf7d4632afcd9c4005e387245e9ac95774e6cc894ae4ccd'
- '81cd6c75a74897831edd4116bb97c71090023abbb14725b96d2a219f67cb5613'
- 'bf3fda048fb1a4f4c49f0daf7faa7e40c630748b33ed27c47bcfabba4014571c'
+sha256sums=(
+ '70fbb82091b3e8dbb4451604438588bc23c14af8398b1d32676eae019c5f3131'
'0639b0c4c9660af33675bf948ca4678d441167f77f7818cc015b7738a53fb8f3'
- )
+)
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+backup=(
+ etc/therion.ini
+ etc/xtherion.ini
+)
- # patch to compile loch with VTK 7.1
- patch -p0 -i ${srcdir}/loch_vtk7.patch
+_builddir="build"
+_sourcedir="${pkgname}-${pkgver}"
- # patch to install in $pkgdir
- patch -p0 -i ${srcdir}/make_install.patch
+prepare() {
+ cd "${pkgname}-${pkgver}"
# patch to get UTF8 and available fonts
patch -p0 -i ${srcdir}/therion_ini.patch
-
- # path to fix loch compilation
- sed -i.bak 's/-DLXLINUX//' loch/Makefile
- sed -i.bak 's/^POBJECTS =.*/POBJECTS =/' loch/Makefile
- sed -i.bak 's/freetype-config --cflags/pkg-config --cflags freetype2/' loch/Makefile
-
- make
}
+build() {
+ cmake \
+ -B "${_builddir}" \
+ -S "${_sourcedir}" \
+ -DUSE_BUNDLED_FMT=OFF \
+ -DUSE_BUNDLED_CATCH2=OFF \
+ -DUSE_BUNDLED_SHAPELIB=OFF \
+ -DCMAKE_INSTALL_PREFIX='/usr'
+
+ make -C "${_builddir}"
+}
+
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ make -C "${_builddir}" DESTDIR="${pkgdir}" install/strip
+
+ mkdir -p "${pkgdir}/etc"
+
+ cp \
+ "${_sourcedir}/therion.ini" \
+ "${_sourcedir}/xtherion/xtherion.ini" \
+ "${pkgdir}/etc"
}
+
+