summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48e36629e236
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Victor Tran <vicr12345 at gmail dot com>
+pkgname=theslate
+pkgver=0.2
+pkgrel=0
+pkgdesc="Text Editor with code highlighting support"
+arch=("x86_64")
+url="https://github.com/vicr123/theslate"
+license=('GPL3')
+depends=('xdg-utils' 'qt5-base')
+makedepends=('git')
+source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/theslate.git')
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ qmake
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ cp "$pkgname-$pkgver/theslate" "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/applications"
+ cp "$pkgname-$pkgver/theslate.desktop" "$pkgdir/usr/share/applications"
+ mkdir -p "$pkgdir/usr/share/icons"
+ cp "$srcdir/$pkgname-$pkgver/icons/icon.svg" "$pkgdir/usr/share/icons/theslate.svg"
+}