summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1b47a3104d5e..bd3fcd8ead34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
# Maintainer: Victor Tran <vicr12345 at gmail dot com>
pkgname=theterminal
-pkgver=2.1
-pkgrel=2
+pkgver=4.0
+pkgrel=1
pkgdesc="Simple Terminal Emulator"
-arch=("x86_64")
-url="https://github.com/vicr123/theterminal"
+arch=("x86_64" "aarch64")
+url="https://github.com/theCheeseboard/theterminal"
license=('GPL3')
-depends=('xdg-utils' 'qtermwidget' 'qt5-base' 'qt5-x11extras' 'the-libs')
-makedepends=('git')
-source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/theterminal#branch=master')
-md5sums=('SKIP')
+depends=('xdg-utils' 'tttermwidget')
+makedepends=('git' 'qt6-tools' 'cmake' 'clang')
+source=("theterminal"::"https://github.com/theCheeseboard/theterminal/archive/v$pkgver.tar.gz")
+sha256sums=('985e820fbc3ff2d70807474813cb0efbc38ef4616400e57055b2f18bcf266323')
build() {
- cd "$pkgname-$pkgver"
- qmake
- make
+ cmake -B build -S "$pkgname-$pkgver" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
}
package() {
- cd "$pkgname-$pkgver"
- make install INSTALL_ROOT=$pkgdir
+ DESTDIR="$pkgdir" cmake --install "build"
}