summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bfe7d0398ad0..b9b936bf014c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,26 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=thiefmd
-pkgver=0.1.1
-_codename=notnanoprep
+pkgver=0.1.2
+_codename=sophistication
pkgrel=1
pkgdesc="The markdown editor worth stealing. Inspired by Ulysses, based on code from Quilter"
arch=('x86_64')
url="https://thiefmd.com"
license=('GPL3')
-depends=('gtkspell3' 'webkit2gtk' 'discount' 'gtksourceview4' 'libxml2' 'libarchive'
+depends=('gtkspell3' 'webkit2gtk' 'discount' 'gtksourceview4' 'libarchive'
'clutter' 'libgee')
makedepends=('git' 'meson' 'vala')
#source=("$pkgname-$pkgver.tar.gz::https://github.com/kmwallio/ThiefMD/archive/v$pkgver-$_codename.tar.gz")
-_commit=a903cdcf0076938778f05bfcf36e4c16a28ca438
+_commit=14ddac2af428864478bf99d14ae0e3ac9fd76a95
source=("git+https://github.com/kmwallio/ThiefMD.git#commit=$_commit"
+ 'git+https://github.com/ThiefMD/ghost-vala.git'
'git+https://github.com/TwiRp/ultheme-vala.git'
+ 'git+https://github.com/ThiefMD/writeas-vala.git'
'git+https://github.com/ThiefMD/libwritegood-vala.git')
sha256sums=('SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -27,8 +31,10 @@ pkgver() {
prepare() {
cd "$srcdir/ThiefMD"
git submodule init
- git config submodule.src/ultheme-vala.url $srcdir/ultheme-vala
- git config submodule.src/libwritegood-vala.url $srcdir/libwritegood-vala
+ git config submodule.src/ghost.url $srcdir/ghost-vala
+ git config submodule.src/ultheme.url $srcdir/ultheme-vala
+ git config submodule.src/writeas.url $srcdir/writeas-vala
+ git config submodule.src/writegood.url $srcdir/libwritegood-vala
git submodule update
}
@@ -37,10 +43,6 @@ build() {
meson compile -C build
}
-check() {
- meson test -C build --print-errorlogs
-}
-
package() {
DESTDIR="$pkgdir" meson install -C build