summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6526cb4e42e5..522443743ffe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=thor-git
pkgver=2.0.r24.g3e320cb
-pkgrel=1
+pkgrel=2
pkgdesc="SFML Extension with various game programming features,
like particles, animations, vector operations"
arch=("x86_64")
@@ -12,25 +12,25 @@ depends=("sfml")
makedepends=("cmake" "git")
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("${pkgname}-${pkgver}::git+https://github.com/Bromeon/Thor.git#branch=master"
+source=("${pkgname}::git+https://github.com/Bromeon/Thor.git#branch=master"
"fix_cmake_module_path.patch")
b2sums=("SKIP"
"b1f082ce989d78abb14ad4615b1babce229f3e245409cbb820bdfd7693e9870ec86a5a586908a5b0d50576d67dd49c585928cf3f4bc94510d9615af7b64c9009")
pkgver() {
printf "%s" \
- $(git -C "${pkgname}-${pkgver}" describe --long --tags \
+ $(git -C "${pkgname}" describe --long --tags \
| sed "s/^v//;s/\([^-]*-g\)/r\1/;s/-/./g")
}
prepare() {
patch --forward --strip=1 \
- --directory="${pkgname}-${pkgver}" \
+ --directory="${pkgname}" \
--input="${srcdir}/fix_cmake_module_path.patch"
}
build() {
- cmake -B "build/" -S "${pkgname}-${pkgver}" \
+ cmake -B "build/" -S "${pkgname}" \
-D THOR_BUILD_DOC:BOOL="OFF" \
-D THOR_BUILD_EXAMPLES:BOOL="OFF" \
-D THOR_SHARED_LIBS:BOOL="ON" \