summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0846827833e2..eb25127c49a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Jonathan Steel <jsteel at aur.archlinux.org>
+# Maintainer: Jonathan Steel <jsteel at archlinux.org>
pkgname=thruk
_pkgver=2.14-2
pkgver=${_pkgver/-/.}
-pkgrel=2
+pkgrel=3
pkgdesc="Multibackend monitoring webinterface for Naemon, Nagios, Icinga and Shinken"
arch=('any')
url="http://thruk.org"
@@ -51,5 +51,8 @@ package() {
chown -R 33:33 "$pkgdir"/var/{lib,log}/thruk/ "$pkgdir"/etc/thruk/panorama/
chmod 770 "$pkgdir"/var/lib/thruk/
- chmod 750 "$pkgdir"/var/log/thruk/
+
+ # Exclude /var/lib/thruk as logrotate doesn't like the permissions there
+ # and there are no logs
+ sed -i 's_^/.* _/var/log/thruk/*.log _' "$pkgdir"/etc/logrotate.d/thruk-base
}