summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d06207cbeee9..c763ceea1cbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ url="https://www.mozilla.org/thunderbird/"
depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib ffmpeg
nss hunspell sqlite ttf-font icu libvpx)
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf libpulse inetutils xorg-server-xvfb
- autoconf2.13 cargo mercurial)
+ autoconf2.13 cargo mercurial clang llvm)
optdepends=('libcanberra: for sound support')
options=(!emptydirs !makeflags)
install=$pkgname.install
@@ -19,13 +19,11 @@ source=(hg+http://hg.mozilla.org/comm-central
$pkgname.desktop
thunderbird-install-dir.patch
no-crmf.diff
- rust-i686.patch
fix-wifi-scanner.diff)
sha512sums=('SKIP'
'5d17bcbda0ca96133f7241a3fb371ba2863f3e67b12d770803e0bc7bb4b3254fc9dc6f78bd8310303abf9b2c62eb1321e63610eb9328c1b9a7b73fde671bc34a'
'3eceeda61891cdfb639be1ef665bd09e857d2e2ada53a5060285a6fc5a894ad88dd271d5cb602db83a4bb747e303f8563562fe90ce3ef02cdfc5d817aa5ab2f4'
- '08572139508d4fd4e2b855d294ebee3286151da80dfeae656ae29b49ce6d72185f4cfa73dfb827c1bcce6bc8c544d0cf4a00164c9059dff316351901601fb6ea'
- 'b38d8a2cb1719d652d93160bfbdfa7cbeca36fbee84b217ca0f5b0b4074b6e151c582b1e0f62901c418fb68a5018f6e21d734d6775836da5b0b44593071c3351'
+ '951667941520e66e7b6aad55619ec2b38364da58c5cf8a71775a3032921cfc0a8e5c7ba14e0df35588175f94a6b4785566d39177ff536ab9cefcbd19a03dc065'
'1bd2804bea1fe8c85b602f8c5f8777f4ba470c9e767ad284cb3d0287c6d6e1b126e760738d7c671f38933ee3ec6b8931186df8e978995b5109797ae86dfdd85a')
_hgrepo="comm-central"
@@ -61,9 +59,6 @@ prepare() {
msg2 "fix-wifi-scanner.diff: https://bugzilla.mozilla.org/show_bug.cgi?id=1314968"
patch -d mozilla -Np1 < ../fix-wifi-scanner.diff
- msg2 "Build with the rust targets we actually ship"
- patch -d mozilla -Np1 < ../rust-i686.patch
-
# API keys
echo -n "$_google_api_key" >google-api-key
echo -n "$_mozilla_api_key" >mozilla-api-key
@@ -79,7 +74,7 @@ ac_add_options --enable-release
ac_add_options --enable-gold
ac_add_options --enable-pie
ac_add_options --enable-optimize="-O2"
-ac_add_options --enable-rust
+#ac_add_options --enable-rust
# Branding
ac_add_options --enable-official-branding