summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD120
1 files changed, 47 insertions, 73 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3aa98e83c732..6dac2e0cedce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,87 +1,61 @@
-# Maintainer: Michael Moroni <michael.moroni @ openmailbox.org>
+# Maintainer: Michael Moroni <michaelmoroni AT disroot DOT org >
+# Contributor: Frederik Schwan <frederik dot schwan at linux dot com>
# Contributor: Cedric Girard <girard.cedric@gmail.com>
# Contributor: Det <nimetonmaili at gmail a-dot com>
-# Contributor: Anthony25 <anthony.ruhier @ gmail.com>
-# Contributor: Bruno Pagani (a.k.a. ArchangeGabriel) <bruno.n.pagani at gmail dot com>
-# Contributor: Glorfindel <glorfindelATsentDOTcom>
-# Contributor: Brizou <brizou @ gmail.com>
-# Contributor: Cedric MATHIEU <me.xenom @ gmail.com>
-# Contributor: coderoar <coderoar @ gmail.com>
-# Contributor: kang <kang @ mozilla.com>
-# Thanks to @xenom, contributor of firefox-nightly
+# Based on [extra]'s thunderbird
_name=thunderbird
_channel=nightly
_lang=it
-_full_name=${_name}-${_channel}
-pkgname=${_full_name}-${_lang}
-pkgdesc='Standalone Mail/News reader from Mozilla — Localized Nightly build'
-url='http://www.mozilla.org/thunderbird/'
-_version=44.0a1
-pkgver=44.0a1.20150814
+pkgname=${_name}-${_channel}-${_lang}
+pkgver=59.0a1.20171126
+_version=59.0a1
pkgrel=1
+pkgdesc="Standalone Mail/News reader - Nightly build (${_lang})"
arch=('i686' 'x86_64')
+url="http://www.mozilla.org/it/thunderbird"
license=('MPL' 'GPL' 'LGPL')
-depends=('alsa-lib' 'cairo' 'dbus-glib' 'desktop-file-utils' 'fontconfig' 'freetype2' 'gtk2' 'hicolor-icon-theme' 'hunspell' 'libevent' 'libjpeg' 'libmng' 'libpng' 'libvpx' 'libxt' 'mozilla-common' 'nspr' 'nss' 'shared-mime-info' 'sqlite' 'startup-notification')
+depends=('alsa-lib' 'cairo' 'dbus-glib' 'desktop-file-utils' 'fontconfig'
+ 'freetype2' 'gtk2' 'hicolor-icon-theme' 'hunspell' 'libevent' 'libjpeg'
+ 'libmng' 'libpng' 'libvpx' 'libxt' 'mozilla-common' 'nspr' 'nss'
+ 'shared-mime-info' 'sqlite' 'startup-notification')
optdepends=('libcanberra: for sound support')
-_base_src="${_name}-${_version}.${_lang}.linux-${CARCH}"
-_base_url="http://ftp.mozilla.org/pub/${_name}/${_channel}/latest-comm-central-l10n"
-_tarball="${_base_src}.tar.bz2"
-source=(
- "${_base_url}/${_tarball}"
- "${_full_name}.desktop"
- 'vendor.js'
-)
-_checksum="$(curl -s "${_base_url}/${_base_src}.checksums" | grep ${_tarball} | grep sha512 | cut -d " " -f1)"
-sha512sums=("${_checksum}"
- '947bb55980dccaa59e13fb69deb02325cbcbb7d7a8685f143710cb31a9fae1da1d81c18fa764d06d50e60464e3c77d781004ab3edf06d68c73a0068435399adf'
- 'bae5a952d9b92e7a0ccc82f2caac3578e0368ea6676f0a4bc69d3ce276ef4f70802888f882dda53f9eb8e52911fb31e09ef497188bcd630762e1c0f5293cc010'
-)
-install=$pkgname.install
-
-pkgver() {
- SRC_VER="${_name}-${_version}.en-US.linux-${CARCH}.txt"
- curl -OR "http://ftp.mozilla.org/pub/${_name}/${_channel}/latest-comm-central/${SRC_VER}"
- echo "${_version}.$(head -n1 ${SRC_VER} | cut -c -8)"
+provides=("thunderbird=$_version")
+install="$pkgname.install"
+
+_url="https://ftp.mozilla.org/pub/${_name}/${_channel}/latest-comm-central-l10n"
+_urlUS="https://ftp.mozilla.org/pub/${_name}/${_channel}/latest-comm-central"
+_src="${_name}-${_version}.${_lang}.linux"
+_srcUS="${_name}-${_version}.en-US.linux"
+source=("${pkgname}.desktop" 'vendor.js')
+# source_i686=("${_url}/${_src}-i686.tar.bz2"{,.asc} "${_urlUS}/${_srcUS}-i686.txt")
+# source_x86_64=("${_url}/${_src}-x86_64.tar.bz2"{,.asc} "${_urlUS}/${_srcUS}-x86_64.txt")
+source_i686=("${_url}/${_src}-i686.tar.bz2" "${_urlUS}/${_srcUS}-i686.txt")
+source_x86_64=("${_url}/${_src}-x86_64.tar.bz2" "${_urlUS}/${_srcUS}-x86_64.txt")
+sha512sums=('869509c2051987fe3f16ba4bbd016c3f8caf3c0204b52f90d33b9f25ed537d78fd208ce8e3d17f40adcf5dbec668176040ca5c803867cb250d209f8c3b78c50d'
+ 'aeb444784732267f1b1e87e6084a776f82a1912c4c2637d2cf1de1c135dd9d41d2ef66d2bd3f9cbd3a79fad32d17ea6e2968ba644d5f887cb66ba6c09a2098f5')
+sha512sums_i686=('b625b4797ceceb55e0c8392aa7072737d7f307830280285630e5a9a77d1146f4a0cfc67a7177aa6c019586873fb6705f8ee0a1876966bfc238c83a2d884ae1f0'
+ '7251a5cd92a83616aa1fc43f7c105dae5252f5e6e41b7efa5c5eea091016ef1fc3e47a4987c275336328c643d111f90204dde21e8eb7aeff2e6cba336f0b7efa')
+sha512sums_x86_64=('b2f8bc12ce952a2f5a14ad7682433568330d60767180069dec7f6a4f781e1e8e261096cebef7411486f9d9d5ce34d02c910b77679b87f6658ef2382ebe28e90c'
+ '7251a5cd92a83616aa1fc43f7c105dae5252f5e6e41b7efa5c5eea091016ef1fc3e47a4987c275336328c643d111f90204dde21e8eb7aeff2e6cba336f0b7efa')
+# sha512sums_i686=('SKIP' 'SKIP' 'SKIP')
+# sha512sums_x86_64=('SKIP' 'SKIP' 'SKIP')
+
+pkgver(){
+ cd "$srcdir"
+ echo "${_version}.$(head -n1 "${_srcUS}-${CARCH}.txt" |cut -c -8)"
}
-# Uncomment check() to enable GnuPG signature verification. You’ll need Mozilla’s GnuPG release key.
-# Their current fingerprint is 14F2 6682 D091 6CDD 81E3 7B6D 61B7 B526 D98F 0353
-#check() {
-# CHECKSUM="${_base_src}.checksums"
-# CHECKSIG="${CHECKSUM}.asc"
-# curl -OR "${_base_url}/${CHECKSUM}"
-# curl -OR "${_base_url}/${CHECKSIG}"
-# gpg --verify ${CHECKSIG} ${CHECKSUM}
-#}
-
package() {
- msg "Downloading..."
- curl -ORz ${_tarball} ${_base_url}
- msg "Extracting..."
- bsdtar -x -f ${_tarball}
- msg "Packaging..."
-
- OPT_PATH="/opt/${_name}-${_version}"
-
- # uncomment this line to remove these
- # rm -rf thunderbird/{extensions,plugins,searchplugins}
- install -d "${pkgdir}"/{usr/{bin,share/applications},opt}
- cp -r thunderbird "${pkgdir}/${OPT_PATH}"
- ln -s "${OPT_PATH}/thunderbird" "${pkgdir}/usr/bin/${_full_name}"
-
- install -Dm644 "${_full_name}.desktop" "${pkgdir}/usr/share/applications/${_full_name}.desktop"
- # Install icons
- for i in 16 32 48
- do
- install -Dm644 "${srcdir}/thunderbird/chrome/icons/default/default${i}.png" "${pkgdir}/usr/share/icons/hicolor/${i}x${i}/apps/${_full_name}.png"
- done
-# install -Dm644 "${srcdir}/thunderbird/icons/mozicon128.png" "${pkgdir}/usr/share/icons/hicolor/128x128/apps/${_full_name}.png"
- # Disable auto-updates
- install -Dm644 "${srcdir}/vendor.js" "${pkgdir}/${OPT_PATH}/defaults/pref/vendor.js"
-
- # Use system-provided dictionaries
- rm -rf "${pkgdir}/${OPT_PATH}"/{dictionaries,hyphenation}
- ln -sf /usr/share/hunspell "${pkgdir}/${OPT_PATH}/dictionaries"
- ln -sf /usr/share/hyphen "${pkgdir}/${OPT_PATH}/hyphenation"
+ cd "$srcdir"
+ install -d "$pkgdir"/{usr/bin,opt}
+ cp -a thunderbird "$pkgdir/opt/$pkgname-$pkgver"
+ cp vendor.js "$pkgdir/opt/$pkgname-$pkgver/defaults/pref/"
+ ln -s "/opt/$pkgname-$pkgver/thunderbird" "$pkgdir/usr/bin/$pkgname"
+ for i in 16x16 22x22 24x24 32x32 48x48 256x256; do
+ install -Dm644 thunderbird/chrome/icons/default/default${i/x*/}.png "$pkgdir/usr/share/icons/hicolor/$i/apps/$pkgname.png"
+ done
+ install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ rm -rf "$pkgdir/opt/$pkgname-$pkgver/dictionaries/"
+ ln -sf /usr/share/hunspell/ "$pkgdir/opt/$pkgname-$pkgver/dictionaries"
}