summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd8cd3913782..8a88d5537d37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: Adrien Wu <adrien.sf.wu@gmail.com>
pkgbase=thundersvm
+_pkgbase=thundersvm
pkgname=('thundersvm' 'python-thundersvm')
pkgver=0.3.4
pkgrel=1
pkgdesc="A Fast SVM Library on GPUs and CPUs"
url="https://github.com/Xtra-Computing/thundersvm"
license=('APL')
-makedepends=(cuda cmake python-wheel)
+makedepends=(cuda cmake python-wheel python-setuptools)
arch=('x86_64')
-source=("https://github.com/Xtra-Computing/${pkgbase}/archive/v${pkgver}.tar.gz")
+source=("https://github.com/Xtra-Computing/${_pkgbase}/archive/v${pkgver}.tar.gz")
sha256sums=('c8b4f7ece312a51ab72ef72e550f7ca3973f5328bc128df64158fe6e3b3b8c0e')
build() {
- cd "$srcdir/$pkgbase-$pkgver"
+ cd "$srcdir/$_pkgbase-$pkgver"
rm -rf build
mkdir build
cd build
@@ -26,7 +27,7 @@ package_thundersvm() {
provides=(thundersvm)
depends=(cuda)
conflicts=(thundersvm-cpu thundersvm-git)
- cd "$srcdir/$pkgbase-$pkgver/build"
+ cd "$srcdir/$_pkgbase-$pkgver/build"
chrpath -d bin/thundersvm-predict
chrpath -d bin/thundersvm-train
install -Dm755 bin/thundersvm-predict "$pkgdir/usr/bin/thundersvm-predict"
@@ -40,6 +41,6 @@ package_python-thundersvm() {
provides=(python-thundersvm)
depends=(thundersvm)
conflicts=(python-thundersvm-cpu)
- cd "$srcdir/$pkgbase-$pkgver/python"
+ cd "$srcdir/$_pkgbase-$pkgver/python"
BUILD_TAG= python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}