summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 144e810f962f..ed181a3cfadd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,26 +7,25 @@ pkgdesc="fast-paced free massively multiplayer online role-playing game"
arch=('x86_64')
url="http://www.tibia.com"
license=('custom')
-depends=('glu' 'libgl' 'libice' 'libxext' 'openssl-1.0' 'pcre' 'qt5-base' 'qt5-declarative')
+depends=('glu' 'libgl' 'libice' 'libxext' 'openssl-1.1' 'pcre' 'qt5-base' 'qt5-declarative')
makedepends=('gendesk' 'python-html2text')
-source=("${pkgname}.tar.gz::http://static.tibia.com/download/tibia.x64.tar.gz"
- "${pkgname}-agreement.php::http://www.tibia.com/support/agreement.php"
- "01_openssl102.patch"
+DLAGENTS=("https::/usr/bin/curl --compressed -fLC - --retry 0 --retry-delay 0 -e %u -o %o %u"
+ "${DLAGENTS[@]}")
+
+source=("${pkgname}.tar.gz::https://static.tibia.com/download/tibia.x64.tar.gz"
+ "${pkgname}-agreement.php::https://www.tibia.com/support/agreement.php"
"02_freetype.patch")
-sha256sums=('47ae3dc80e892bf57c2729e507eecadf2ff73263eca46c5edc860b43b772ac4f'
- '1200d3d5a77c8408a79a92c2fb4bdb5fa123b928aa036a32d2951e2459f0f7d9'
- 'e9e6cdd4e2954ae0838dc427a92871bb9cacdacb0523598c60287a05f8568d1f'
- '3cdf107369e4366aa5fc6d1b90ba0b41bd3d19abeb418fb85a693d74c3ece736')
+sha256sums=('SKIP'
+ 'SKIP'
+ '55d87bd8f32728cd47757a195102e2af2d10a1501d9370af86606b2c75211515')
prepare() {
gendesk -f -n
html2text "${pkgname}-agreement.php" > LICENSE
cd Tibia
- # Tibia relies on openssl 1.0.x
- patch -Np0 -i "${srcdir}/01_openssl102.patch"
# Tibia relies on specific freetype version
patch -Np0 -i "${srcdir}/02_freetype.patch"
}