summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ddd748cfbfdc..202f06046129 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
# Maintainer: Simon Legner <Simon.Legner@gmail.com>
pkgname=tilemaker
-pkgver=r14.6a994ee
-pkgver() {
- cd "$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
+pkgver=3.0.0
pkgrel=1
pkgdesc="Convert OpenStreetMap .pbf files into vector tiles without the stack"
arch=('i686' 'x86_64')
url="https://github.com/systemed/tilemaker"
license=('custom')
-depends=('boost-libs' 'luabind' 'protobuf' 'sqlite')
-source=("$pkgname::git+https://github.com/systemed/$pkgname")
-md5sums=('SKIP')
+install=$pkgname.install
+depends=('boost-libs' 'lua>=5.1' 'protobuf' 'sqlite' 'shapelib' 'rapidjson')
+makedepends=('boost' 'git')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/systemed/$pkgname/archive/v$pkgver.tar.gz")
+sha512sums=('33c568d0107bf0cd9510f860d221fb4980bcf9ba07de2063c8842f0436aad612f1c17464d4bbe00547605d0066a00ec8ec00e1832169c05f48135f7f51898bed')
build() {
- cd "$pkgname"
- make
+ cmake -B build -S "$pkgname-$pkgver" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -Wno-dev
+ cmake --build build
}
package() {
- cd "$pkgname"
- install -Dm 0755 tilemaker $pkgdir/usr/bin/tilemaker
- install -Dm 0644 LICENCE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -Dm 0755 build/tilemaker $pkgdir/usr/bin/tilemaker
+ install -Dm 0644 "$pkgname-$pkgver"/LICENCE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
}