summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e59518560ac..85eb5124e0f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: "Amhairghin" Oscar Garcia Amor (https://ogarcia.me)
pkgname=timeline
-pkgver=1.3
-pkgrel=2
+pkgver=1.4
+pkgrel=1
pkgdesc="A plain-text based distributed social network build on top of git configuration manager"
arch=('any')
url="https://ajdiaz.me/timeline/"
@@ -11,9 +11,14 @@ depends=('bash' 'git')
conflicts=('timeline-git')
source=("https://github.com/ajdiaz/${pkgname}/archive/${pkgver}.tar.gz"
"${pkgname}.service")
-sha256sums=('8e6d0cfdd2ebbb17704e88ef954b4e13155800bc235c7eb0da17ca1ef88e7440'
+sha256sums=('4a1fa7c9188f83b50ffa77fc5fd494bfbe5fe2929361df10142af838aaa2cc98'
'ef063a64b2e38988cf7b7395161351e537e50719f4d77fa3d180e25b911371fd')
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ sed -i "s/\$(shell git describe --tags --long --dirty)/${pkgver}/g" Makefile
+}
+
build() {
cd "${pkgname}-${pkgver}"
make clean && make