summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e513a9dd8f9..1d53a282dc41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ set -u
_ubver='19.08.1'; _libgee='libgee>=0.18.0'
pkgname='timeshift'
pkgver="${_ubver}"
-pkgrel='1'
+pkgrel='2'
pkgdesc='A system restore utility for Linux'
arch=('i686' 'x86_64')
#url='https://launchpad.net/~teejee2008/+archive/ubuntu/ppa'
@@ -46,8 +46,14 @@ install="${pkgname}-install.sh"
_github='teejee2008'
_verwatch=("https://github.com/${_github}/${pkgname}/releases.atom" '\s\+<title>Timeshift v\([0-9\.]\+\)</title>.*' 'f')
_srcdir="${pkgname}-${pkgver}"
-source=("${pkgname}_v${pkgver}.tgz::https://github.com/${_github}/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('ab56331f97c1616b889e69adccedeca06f0150e964eea631b52c9bd399f77604')
+source=(
+ "${pkgname}_v${pkgver}.tgz::https://github.com/${_github}/${pkgname}/archive/v${pkgver}.tar.gz"
+ 'pr476.patch'
+)
+md5sums=('ca8f06acac4225a6f1f48fba0c1eac72'
+ '84164d8ff50bd28cc8d534272d363ef4')
+sha256sums=('ab56331f97c1616b889e69adccedeca06f0150e964eea631b52c9bd399f77604'
+ '6a4889a8923c0752e024eea2a30416185ebfe236231cf387a5576810b6ad6de0')
#sha256sums[0]='SKIP'
prepare() {
@@ -55,6 +61,10 @@ prepare() {
cd "${_srcdir}"
# ndowens04 2019-01-30 02:45
#sed -e 's:--thread:& Core/AppExcludeEntry.vala:' -i 'src/makefile'
+
+ #cp -p src/Utility/AsyncTask.vala{,.orig}
+ #diff -pNau5 src/Utility/AsyncTask.vala{.orig,} > 'pr476.patch'
+ patch -Nbup0 -i "${srcdir}/pr476.patch"
set +u
}