summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 17 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b92e032ac77e..ce65e8092f15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Nick Econopouly <wry at mm dot st>
pkgname=tiny-irc-client-git
-pkgver="0.4.0"
+pkgver="0.4.3"
pkgrel=1
pkgdesc="A console IRC client"
arch=('x86_64')
@@ -9,16 +9,27 @@ url="https://github.com/osa1/tiny"
license=('MIT')
depends=('openssl' 'dbus')
makedepends=('git' 'rust-nightly')
+source=(git+$url)
+sha512sums=(SKIP)
build() {
- return 0
+ # Installs the Rust nightly toolchain to a temporary
+ # directory. If you already have the toolchain installed,
+ # e.g. via the script at https://rustup.rs/ or another
+ # package, you can remove the rust-nightly dependancy and
+ # comment out the following three commands.
+
+ mkdir nightly
+ export RUSTUP_HOME=$(pwd)/nightly
+ rustup toolchain install nightly
+
+ # build tiny
+ cd tiny
+ cargo +nightly build --release
}
package() {
- git clone "$url.git"
cd tiny
- cargo +nightly build --release
install -Dm755 target/release/tiny "$pkgdir/usr/bin/tiny"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/tiny/LICENSE"
-
-} \ No newline at end of file
+}