summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8bf3feeba104..33c16724085a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,25 @@
pkgname=tinypy
pkgver=1.1
-pkgrel=1
+pkgrel=2
pkgdesc="A minimalist implementation of python in 64k of code"
-arch=('i686')
-url="http://code.google.com/p/tinypy/"
+arch=('i686' 'x86_64')
+url="https://github.com/philhassey/tinypy"
license=('MIT')
makedepends=('python')
optdepends=('sdl: for pygame module')
-source=(http://${pkgname}.googlecode.com/files/${pkgname}-${pkgver}.tar.gz)
-md5sums=('1091300b72fcc1f75cafb91bea92772e')
+source=(https://github.com/philhassey/tinypy/archive/1.1.tar.gz setup.py_python2.diff)
+md5sums=('2cf555944ad8ed82375c6c4e7c3ad338' '08a8a95b04cb9be079b920397ce397cf')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
- python setup.py linux pygame
+ mkdir build
+ patch -u setup.py ../setup.py_python2.diff
+ python2 setup.py linux pygame
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
mkdir -p ${pkgdir}/usr/bin \
${pkgdir}/usr/share/licenses/${pkgname}
install -D -m755 ${srcdir}/${pkgname}-${pkgver}/build/${pkgname} ${pkgdir}/usr/bin/