summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 567ad01d6030..1a81a76b039e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: Martin Hundebøll <martin@hundeboll.net>
pkgname=tio
-pkgver=2.7
+pkgver=3.0
pkgrel=1
pkgdesc="The simple TTY terminal I/O application"
-url="http://tio.github.io/"
+url="https://tio.github.io/"
arch=('x86_64' 'i686' 'arm' 'armv7h' 'armv6h' 'aarch64')
license=('GPL-2.0-or-later')
-depends=('glibc' 'libinih' 'bash-completion')
+depends=('glibc' 'libinih' 'lua' 'glib2')
+optdepends=('bash-completion: bash completion support')
makedepends=('meson')
source=("https://github.com/tio/tio/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz")
-sha256sums=('bf8fe434848c2c1b6540af0b42503c986068176ddc1a988cf02e521e7de5daa5')
+sha256sums=('b7ec8eab6c29a3821e3f1239cf6baa84ef634ea2188ffa93d7a276c89338961e')
build() {
cd "$srcdir/$pkgname-$pkgver"
- meson --prefix=/usr --buildtype=plain . build
+ meson setup --prefix=/usr --buildtype=plain . build
meson compile -C build
}