summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..176f385c5fd0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Arch-Jason <arch-jason@outlook.com>
+pkgname=tminesweeper
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Minesweeper game in terminal"
+arch=(any)
+url="https://github.com/langong-dev/tminesweeper"
+license=('MIT')
+depends=('bash')
+makedepends=('gcc' 'git')
+source=("git+$url")
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname/"
+ g++ main.cpp -o "$pkgname"
+}
+
+package() {
+ cd "$pkgname"
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/$pkgname"
+ cp "$pkgname" "$pkgdir/usr/bin"
+ chmod 755 "$pkgdir/usr/bin/$pkgname"
+ cp -r * "$pkgdir/usr/share/$pkgname"
+}