summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..995b668559c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Benjamin Bädorf <aur at benjaminbaedorf dot eu>
+# Maintainer: Siddarth Dushantha <siddarth dot dushanta at gmail dot com>
+
+pkgname=tmpmail-git
+_pkgname=tmpmail
+pkgver=2.g177dcc3
+pkgrel=1
+pkgdesc="A temporary email right from your terminal"
+arch=('any')
+url="https://github.com/sdushantha/tmpmail"
+license=('MIT')
+makedepends=('git')
+depends=('w3m' 'curl' 'jq')
+provides=()
+conflicts=()
+source=("$_pkgname::git+https://github.com/sdushantha/tmpmail.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ echo "$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+}
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ chmod +x ./tmpmail
+ mkdir -p "$pkgdir/usr/bin"
+ cp ./tmpmail "$pkgdir/usr/bin"
+}