summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 11 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83775e3134f8..b31fbebaf463 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,29 @@
# Maintainer: willemw <willemw12@gmail.com>
# Contributor: Daniel YC Lin <dlin.tw at gmail>
-_pkgname=tmux-mem-cpu-load
-pkgname=$_pkgname-git
-pkgver=3.4.0.r10.g75b9ea7
+pkgname=tmux-mem-cpu-load-git
+pkgver=3.4.0.r25.gd5007d4
pkgrel=1
pkgdesc="CPU, RAM memory, and load monitor for use with tmux"
url="https://github.com/thewtex/tmux-mem-cpu-load"
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('APACHE')
makedepends=('cmake')
-provides=($_pkgname)
-conflicts=($_pkgname)
-source=($pkgname::git+https://github.com/thewtex/tmux-mem-cpu-load)
-md5sums=('SKIP')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=($pkgname::git+$url.git)
+sha256sums=('SKIP')
pkgver() {
- cd $pkgname
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git -C $pkgname describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd $pkgname
- cmake .
- make
+ cmake -B build -S $pkgname -DCMAKE_BUILD_TYPE=None -DCMAKE_INSTALL_PREFIX=/usr -Wno-dev
+ make -C build
}
package() {
- cd $pkgname
- install -Dm755 tmux-mem-cpu-load "$pkgdir/usr/bin/tmux-mem-cpu-load"
+ install -Dm755 build/tmux-mem-cpu-load "$pkgdir/usr/bin/tmux-mem-cpu-load"
}