summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 174900c6ff16..f13592af7270 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
-# Maintainer: Márton Szabó <notramo@vipmail.hu>
+# Maintainer: Márton Szabó < echo "bm90cmFtb0B2aXBtYWlsLmh1Cg=="|base64 -d >
+
pkgname=tokei-git
-pkgver=6.0.1
+pkgver=v7.0.1.r17.16d49fc
pkgrel=1
pkgdesc='A blazingly fast CLOC(Count Lines Of Code) program'
arch=('i686' 'x86_64')
@@ -12,6 +13,11 @@ conflicts=('tokei')
source=("git+https://github.com/Aaronepower/tokei")
sha512sums=(SKIP)
+pkgver() {
+ cd "${srcdir}/tokei"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
build() {
cd "${srcdir}/tokei"