summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59404bda5d0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Tyler Langlois <ty |at| tjll |dot| net>
+
+pkgname=topbeat-bin
+_pkgbase=${pkgname%%-bin}
+pkgver=1.0.0_beta3
+_pkgver=${pkgver/_/-}
+pkgrel=1
+pkgdesc='An open source server monitoring agent that stores metrics in Elasticsearch (precompiled)'
+arch=('i686' 'x86_64')
+url="https://www.elastic.co/products/beats"
+license=('APACHE')
+backup=("etc/$_pkgbase/$_pkgbase.yml")
+optdepends=('elasticsearch: for running standalone installation')
+options=('!strip')
+provides=("$_pkgbase")
+conflicts=("$_pkgbase")
+source=("$_pkgbase.service")
+sha256sums=('62f5b613d9464e4d8b1074c1a54b95cbd1c6615f0c788f1d9093becbdbc6c45d')
+
+source_i686=("https://download.elastic.co/beats/$_pkgbase/$_pkgbase-$_pkgver-i686.tar.gz")
+source_x86_64=("https://download.elastic.co/beats/$_pkgbase/$_pkgbase-$_pkgver-x86_64.tar.gz")
+sha256sums_i686=('e3a7772b7eb25cb3627b29acc61e3d874dbae6aef0b6e1c5648ebe376d6b89ee')
+sha256sums_x86_64=('42a8ab17f9638eb62397f79b21198763cc8c8c26370c615047a4656df624409c')
+
+package() {
+ cd "$srcdir/$_pkgbase-$_pkgver-$CARCH"
+
+ install -D -m755 $_pkgbase "$pkgdir/usr/bin/$_pkgbase"
+ install -D -m644 $_pkgbase.yml "$pkgdir/etc/$_pkgbase/$_pkgbase.yml"
+ install -D -m644 $_pkgbase.template.json \
+ "$pkgdir/etc/$_pkgbase/$_pkgbase.template.json"
+
+ install -D -m644 "$srcdir/$_pkgbase.service" \
+ "$pkgdir/usr/lib/systemd/system/$_pkgbase.service"
+}