summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 9 insertions, 44 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f7ed8f7d7ede..ec8f1f88ed1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,59 +1,24 @@
-# Maintainer: coco
-# Co-Maintainer: dramm <dramm at archlinux dot email>
-# Contributor: thatgeek
+# Maintainer: ABOhiccups <info@abohiccups.com>
+# Contributor: Arch Linux Community
# Contributor: TorGuard Support <support@torguard.com>
pkgname=torguard
-pkgver=4.8.10
-build=build.167.1+g228f8ff
+pkgver=4.8.29
+build=build.286.1+g70e4e51
pkgrel=1
pkgdesc="TorGuard VPN Software
Stay private online with TorGuard's anonymous VPN software and connect to 37+ countries worldwide."
arch=('x86_64')
url="https://www.torguard.net"
-depends=('iproute2'
- 'qt5-websockets'
- 'qt5-declarative'
- 'qt5-quickcontrols2'
- 'qt5-svg'
- 'shadowsocks-libev'
- 'unbound'
- 'stunnel')
+depends=('iproute2' 'psmisc' 'libxkbcommon-x11')
optdepends=('wireguard-tools: wireguard support')
license=(custom)
-source_x86_64=("https://updates.torguard.biz/Software/Linux/torguard-v${pkgver}-amd64-arch.tar.gz")
-source=('torguard.sysusers')
-sha256sums_x86_64=('946bf91e881650660281c5ec184562653b84ac638ddcfe7827b90fc83aa7fc67')
-sha256sums=('b1f954c54725794f94009c72e12746f203ce6dd4318a19ad0c10d5d8684cd873')
-
-prepare() {
- tar -xf "${srcdir}/${pkgname}-v${pkgver}-${build}-amd64-arch/torguard-v${pkgver}-${build}-amd64-arch.tar"
-}
+source=("https://updates.torguard.biz/Software/Linux/torguard-v${pkgver}-amd64-arch.tar.gz")
+sha256sums=('1a828c7d13de59f9db34489ba5407bf2201181280aa6c6af1e4241982b0d1925')
+install=torguard.install
package() {
- mkdir "$pkgdir"/opt/
- mkdir "$pkgdir"/opt/torguard/
- mkdir "$pkgdir"/opt/torguard/bin/
- mkdir "$pkgdir"/opt/torguard/doc/
-
- cp "${srcdir}/${pkgname}-v${pkgver}-${build}-amd64-arch/opt/torguard/bin/torguard" "${pkgdir}/opt/torguard/bin/"
- cp "${srcdir}/${pkgname}-v${pkgver}-${build}-amd64-arch/opt/torguard/bin/torguard-wrapper" "${pkgdir}/opt/torguard/bin/"
- cp "${srcdir}/${pkgname}-v${pkgver}-${build}-amd64-arch/opt/torguard/bin/openconnect" "${pkgdir}/opt/torguard/bin/"
- cp "${srcdir}/${pkgname}-v${pkgver}-${build}-amd64-arch/opt/torguard/bin/openvpn" "${pkgdir}/opt/torguard/bin/"
- cp "${srcdir}/${pkgname}-v${pkgver}-${build}-amd64-arch/opt/torguard/bin/vpnc-script" "${pkgdir}/opt/torguard/bin/"
- cp -r "${srcdir}/${pkgname}-v${pkgver}-${build}-amd64-arch/opt/torguard/doc" "${pkgdir}/opt/torguard" -R
- cp -r "${srcdir}/${pkgname}-v${pkgver}-${build}-amd64-arch/usr" "${pkgdir}/" -R
-
- find "$pkgdir"/opt/torguard/ -type f -exec chmod 644 {} \;
- find "$pkgdir"/opt/torguard/ -name torguard -exec chmod 755 {} \;
- find "$pkgdir"/opt/torguard/ -name torguard-wrapper -exec chmod 755 {} \;
- find "$pkgdir"/opt/torguard/ -name openconnect -exec chmod 755 {} \;
- find "$pkgdir"/opt/torguard/ -name openvpn -exec chmod 755 {} \;
- find "$pkgdir"/opt/torguard/ -name vpnc-script -exec chmod 755 {} \;
+ bsdtar -xf "${srcdir}/torguard-v${pkgver}-${build}-amd64-arch/torguard-v${pkgver}-${build}-amd64-arch.tar" -C "$pkgdir" -s"/torguard-v${pkgver}-${build}-amd64-arch//"
install -d "$pkgdir"/usr/bin/
ln -s /opt/torguard/bin/torguard-wrapper "$pkgdir"/usr/bin/torguard
- ln -s /usr/bin/ss-local "$pkgdir"/opt/torguard/bin/ss-local
- ln -s /usr/bin/stunnel "$pkgdir"/opt/torguard/bin/stunnel
-
- install -Dm644 ${pkgname}.sysusers "${pkgdir}"/usr/lib/sysusers.d/${pkgname}.conf
}