summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 20 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 75917c729602..ece95317772d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,30 @@
-# Maintainer: Florian Bruhin <archlinux.org@the-compiler.org>
+# Maintainer: Marco Rubin <marco.rubin@protonmail.com>
+# Contributor: Florian Bruhin <archlinux.org@the-compiler.org>
# Contributor: Roman G <drakosha@au.ru>
pkgname=torrentinfo
-pkgver=1.0.2
+pkgver=1.8.7
pkgrel=3
pkgdesc="Bittorrent .torrent file parser and summariser"
arch=('any')
-url="http://vrai.net/project.php?project=torrentinfo"
-license=('GPL2')
-depends=('python2')
-source=(http://vrai.net/files/software_projects/$pkgname/$pkgname-$pkgver.tar.gz)
-md5sums=('0ab4400f43a9509cb858d07917603cda')
+url="https://github.com/Fuuzetsu/torrentinfo"
+license=(GPL2)
+depends=(python)
+makedepends=(git python-build python-installer python-setuptools python-wheel)
+source=("git+$url#commit=3c9b3ba80c867ba28e8ce0982fec8ea5369df8ef")
+b2sums=('SKIP')
-build() {
- cd "$srcdir/$pkgname-$pkgver"
+prepare() {
+ cd $pkgname
+ sed -i "s/os.name is/os.name ==/g" setup.py # fix warning
+}
- python2 setup.py install --root="$pkgdir" -O1
+build() {
+ cd $pkgname
+ python -m build --wheel --no-isolation
}
-# vim:set ts=2 sw=2 et:
+package() {
+ cd $pkgname
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}