summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23c7a8588d46..676da7632518 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname=touchegg
pkgname=${_pkgname}-git
pkgver=r322.a82d299
-pkgrel=2
+pkgrel=3
pkgdesc='Linux multi-touch gesture recognizer'
arch=('x86_64')
url='https://github.com/JoseExposito/touchegg'
@@ -31,9 +31,10 @@ build() {
}
package() {
- #cd "$srcdir/${_pkgname}/build"
- #DESTDIR="$pkgdir" make install
- install -D "$srcdir/build/touchegg" "$pkgdir/usr/bin/touchegg"
- install -Dm 0644 "$srcdir/${_pkgname}/installation/touchegg.conf" "$pkgdir/usr/share/touchegg/touchegg.conf"
- install -Dm 0644 "$srcdir/${_pkgname}/installation/touchegg.service" "$pkgdir/usr/lib/systemd/system/touchegg.service"
+ DESTDIR="$pkgdir" make -C build install
+
+ # /lib is a symlink to /usr/lib on most Arch systems, this
+ # workaround is needed to prevent alpm from failing with
+ # a conflict
+ [ -d "$pkgdir/lib" ] && mv "$pkgdir/lib" "$pkgdir/usr/lib"
}