summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 505d20dc00db..562b4e2a9efc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Ted Alff <twa022 at gmail dot com>
pkgname=touchpad-indicator-git
-pkgver=2.2.3.ubuntu20.04.0.r131.bc21ab5
-pkgrel=3
+pkgver=2.2.3.ubuntu20.04.0.r133.b789619
+pkgrel=1
pkgdesc="An indicator for the touchpad"
arch=('any')
url="https://github.com/atareao/Touchpad-Indicator"
license=('GPL3')
depends=('gdk-pixbuf2' 'libappindicator-gtk3' 'libnotify' 'lsb-release' 'librsvg'
'python-xlib' 'python-pyudev' 'python-dbus' 'python-evdev' 'xorg-xinput')
-makedepends=('git' 'dpkg')
+makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("${pkgname%-git}::git+https://github.com/atareao/Touchpad-Indicator.git")
@@ -17,9 +17,9 @@ sha256sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
- printf "%s.r%s.%s" "$(dpkg-parsechangelog --show-field Version | sed 's/-/./')" \
- "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
+ printf "%s.r%s.%s" "$(head -n 1 debian/changelog | cut -d'(' -f 2 | cut -d')' -f 1 | \
+ sed 's/-/./')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ }
prepare() {
cd "$srcdir/${pkgname%-git}"