summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 18 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57dd3b2edb6c..7413ec8cb5eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,37 @@
# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
pkgname=touplite
-pkgver=1.0
+pkgver=2.1.17309.2020616
pkgrel=1
pkgdesc="A port of the ToupTek Photonics's PC software ToupLite for Linux"
arch=('i686' 'x86_64')
url="http://touptek.com/download/showdownload.php?lang=en&id=28"
-depends=('qt4')
-license=('unknown')
-source=("http://touptek.com//upload/download/ToupLiteLinux.tgz")
-md5sums=('7532b402b30adfe613d1356478c30892')
+depends=(fontconfig dbus libglvnd libxrender freetype2)
+license=('custom')
+source_x86_64=("http://www.touptek.com/upload/download/ToupTekToupLite.x64.tar.bz2")
+source_i686=("http://www.touptek.com/upload/download/ToupTekToupLite.x86.tar.bz2")
+sha256sums_x86_64=('fdeabe108b4cfcb22aaf7a07dd94d65b215bf098657dd8174b0176ef2e09bb3f')
+sha256sums_i686=('640fc3132181a6ae08a56ff6c466e87af45dd8d6ed8dc0b6e18fbafab05e8fa4')
+options=('!strip')
prepare() {
- cd "$srcdir"
-
- if [ "$CARCH" == "x86_64" ]
- then
- chmod u+rw ToupLite-${pkgver}-x64.tgz
- tar xvzf ToupLite-${pkgver}-x64.tgz
- tail -n +41 ToupLite-${pkgver}-x64.run | tar xvz
- else
- chmod u+rw ToupLite-${pkgver}-x86.tgz
- tar xvzf ToupLite-${pkgver}-x86.tgz
- tail -n +41 ToupLite-${pkgver}-x86.run | tar xvz
- fi
-
- cd ToupLite
- tar xzvf res.tar.gz
+ ARCH_STR=$( [ "$CARCH" == "x86_64" ] && echo -n x64 || echo -n x86 )
+ sed -n -e '1,/^exit 0$/!p' ToupTekToupLite.${ARCH_STR}.sh | tar xvz
+ rm -f ToupTekToupLite.${ARCH_STR}.sh
}
package() {
- cd "$srcdir/ToupLite"
-
- install -Dm644 libtoupcam.so libtoupnam.so -t "${pkgdir}/usr/local/lib"
- install -Dm755 ToupLite "${pkgdir}/usr/local/ToupLite/ToupLite"
+ install -Dm755 touplite "${pkgdir}/usr/local/ToupLite/touplite"
+ install -Dm644 libtoupcam.so libtoupnam.so -t "${pkgdir}/usr/local/ToupLite"
- mkdir -p "${pkgdir}/usr/bin/"
- ln -s "/usr/local/ToupLite/ToupLite" "${pkgdir}/usr/bin/ToupLite"
+ install -dm755 "${pkgdir}/usr/bin/"
+ ln -s "/usr/local/ToupLite/touplite" "${pkgdir}/usr/bin/touplite"
- install -Dm644 res/*.xml res/ToupLite.png -t "${pkgdir}/usr/local/ToupLite/res/"
+ install -Dm644 i18n/*.xml -t "${pkgdir}/usr/local/ToupLite/i18n/"
+ install -Dm644 touplite.png -t "${pkgdir}/usr/local/ToupLite/"
install -Dm644 99-toupcam.rules -t "${pkgdir}/usr/lib/udev/rules.d/"
- install -Dm755 res/ToupLite.desktop -t "${pkgdir}/usr/share/applications"
+ install -Dm755 touplite.desktop -t "${pkgdir}/usr/share/applications"
}
# vim:set ts=2 sw=2 et: