summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fbe573d63b6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Michael Serajnik <ms dot mserajnik dot at>
+pkgname=traffictoll-git
+_pkgname=TrafficToll
+pkgver=r35.0add8b6
+pkgrel=1
+pkgdesc="NetLimiter-like traffic shaping for Linux"
+arch=('any')
+url="https://github.com/cryzed/${_pkgname}"
+license=('GPL3')
+depends=('python' 'python-loguru' 'python-psutil' 'python-ruamel-yaml')
+makedepends=('python-pip' 'python-poetry')
+conflicts=('traffictoll')
+source=("git+https://github.com/cryzed/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ poetry build
+}
+
+package() {
+ INSTALL_PATH="${srcdir}/${_pkgname}/dist/${_pkgname}-*.whl"
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps --no-warn-script-location $INSTALL_PATH
+}