summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD106
1 files changed, 58 insertions, 48 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c721ac57951a..aa8da984fed7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,35 +6,37 @@
_pkgbase=transmission
_pkgname=transmission-cli
pkgname=transmission-cli-git
-pkgver=4.0.0.beta.3.r2.gcc4cbff04
+pkgver=4.0.3.r160.g8169d524e
pkgrel=1
arch=(x86_64 armv7h)
-url="http://www.transmissionbt.com/"
-license=(MIT)
-pkgdesc='Fast, easy, and free BitTorrent client (CLI tools, daemon and web client)'
-depends=(curl libevent libsystemd miniupnpc dht libb64 libnatpmp libdeflate libpsl libutp)
-makedepends=(cmake publicsuffix-list git)
-conflicts=(transmission-cli)
-replaces=(transmission-cli)
-provides=(transmission-cli)
+url="https://www.transmissionbt.com/"
+license=(GPL)
+pkgdesc='Fast, easy, and free BitTorrent client (CLI tools and daemon - without web client) - git version'
+depends=(
+ curl
+ dht
+ libb64
+ libdeflate
+ libevent
+ libnatpmp
+ libpsl
+ libsystemd
+ miniupnpc
+)
+makedepends=(
+ cmake
+ git
+ ninja
+)
+conflicts=("$_pkgname")
+provides=("$_pkgname")
+options=(!lto)
source=("git+https://github.com/transmission/transmission.git"
- transmission-cli.sysusers
- transmission-cli.tmpfiles
- "git+https://github.com/google/googletest.git"
- "git+https://github.com/transmission/utfcpp#branch=post-3.2.1-transmission"
- "git+https://github.com/transmission/libutp#branch=post-3.4-transmission"
- "git+https://github.com/transmission/fmt#branch=9-x-y"
- "git+https://github.com/transmission/fast_float.git"
- "git+https://github.com/transmission/wide-integer.git")
+ transmission-cli.sysusers
+ transmission-cli.tmpfiles)
sha256sums=('SKIP'
'641310fb0590d40e00bea1b5b9c843953ab78edf019109f276be9c6a7bdaf5b2'
- '1266032bb07e47d6bcdc7dabd74df2557cc466c33bf983a5881316a4cc098451'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+ '1266032bb07e47d6bcdc7dabd74df2557cc466c33bf983a5881316a4cc098451')
pkgver() {
cd $_pkgbase
@@ -44,47 +46,54 @@ pkgver() {
prepare() {
cd $_pkgbase
git submodule init
- git config submodule.third-party/googletest.url "$srcdir/googletest"
- git config submodule.third-party/utfcpp.url "$srcdir/utfcpp"
- git config submodule.third-party/libutp.url "$srcdir/libutp"
- git config submodule.third-party/fmt.url "$srcdir/fmt"
- git config submodule.third-party/fast_float.url "$srcdir/fast_float"
- git config submodule.third-party/wide-integer.url "$srcdir/wide-integer"
-
git -c protocol.file.allow=always submodule update \
+ third-party/fast_float \
+ third-party/fmt \
third-party/googletest \
- third-party/utfcpp \
third-party/libutp \
- third-party/fmt \
- third-party/fast_float \
+ third-party/small \
+ third-party/utfcpp \
third-party/wide-integer
}
build() {
cd $_pkgbase
- mkdir -p build
- cd build
+ CFLAGS+=" -ffat-lto-objects"
- cmake .. \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX="/usr" \
+ cmake -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
-DENABLE_CLI=ON \
+ -DENABLE_DAEMON=ON \
-DENABLE_GTK=OFF \
+ -DENABLE_MAC=OFF \
+ -DENABLE_NLS=OFF \
-DENABLE_QT=OFF \
- -DENABLE_WEB=OFF \
- -DINSTALL_LIB=ON \
- -DUSE_SYSTEM_UTP=OFF \
- -DUSE_SYSTEM_DHT=ON \
- -DUSE_SYSTEM_B64=ON \
- -DUSE_SYSTEM_NATPMP=ON
-
- make
+ -DENABLE_TESTS=OFF \
+ -DENABLE_UTILS=ON \
+ -DENABLE_UTP=ON \
+ -DINSTALL_LIB=OFF \
+ -DINSTALL_WEB=OFF \
+ -DREBUILD_WEB=OFF \
+ -DUSE_SYSTEM_B64=ON \
+ -DUSE_SYSTEM_DEFLATE=ON \
+ -DUSE_SYSTEM_DHT=ON \
+ -DUSE_SYSTEM_EVENT2=ON \
+ -DUSE_SYSTEM_MINIUPNPC=ON \
+ -DUSE_SYSTEM_NATPMP=ON \
+ -DUSE_SYSTEM_PSL=ON \
+ -DUSE_SYSTEM_UTP=OFF \
+ -DWITH_APPINDICATOR=OFF \
+ -DWITH_CRYPTO=openssl \
+ -DWITH_INOTIFY=OFF \
+ -DWITH_KQUEUE=OFF \
+ -S . -B build
}
package() {
cd $_pkgbase/build
- make DESTDIR="$pkgdir" install
+ env DESTDIR="$pkgdir" ninja install
install -Dm644 ../daemon/transmission-daemon.service \
"$pkgdir/usr/lib/systemd/system/transmission.service"
@@ -95,3 +104,4 @@ package() {
install -Dm644 "$srcdir/$_pkgname.tmpfiles" \
"$pkgdir/usr/lib/tmpfiles.d/transmission.conf"
}
+