summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6337d4774aa8..09ec7f4e6766 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,17 @@
# Contributor: TheGoliath
pkgname=triehash
pkgver=0.3
-pkgrel=1
+pkgrel=2
pkgdesc="Generator for order-preserving minimal perfect hash functions in C"
arch=('any')
url="https://github.com/julian-klode/triehash"
license=('MIT')
groups=('')
depends=('perl')
-options=('!strip' '!emptydirs')
-source=("http://archive.ubuntu.com/ubuntu/pool/universe/t/triehash/triehash_0.3-2_all.deb")
-sha512sums=('7fb1d24d93c944873cf37785ee59c15f946017f9fa9eeaec92ca23b1d08a8f6fbd0ee1d3b7f81066d499e9cf2dbdeaa45d859f9e7d79a61dba577239f0d3e50b')
-
-package(){
-
- # Extract package data
- tar xf data.tar.xz -C "${pkgdir}"
+source=("https://github.com/julian-klode/triehash/archive/v${pkgver}.tar.gz")
+sha512sums=('6a9591dc095cce36777275c1886c844c447e69d5b2ea705b258ca30ec6ea1075f14e293852924edd30c94505bd7bccd7f4c60173e10ec7e70dbddf9700b8bef7')
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 "${pkgname}.pl" "$pkgdir/usr/bin/$pkgname"
}