summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 67ae98385c4e..4713a54315a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@
# Contributor: Simon Pintarelli <simon.pintarelli@gmail.com>
# Contributor: Feng Wang <wanng.fenng@gmail.com>
pkgname=trilinos
-pkgver=13.4.1
+pkgver=14.0.0
_pkgver=${pkgver//./-}
-pkgrel=2
+pkgrel=1
pkgdesc="algorithms for the solution of large-scale scientific problems"
arch=('x86_64')
url="http://trilinos.org"
@@ -18,8 +18,8 @@ provides=('trilinos-sacado' 'zoltan')
checkdepends=('cmake')
source=("https://github.com/trilinos/Trilinos/archive/refs/tags/trilinos-release-$_pkgver.tar.gz"
'compiler-errors.patch')
-sha256sums=('5465cbff3de7ef4ac7d40eeff9d99342c00d9d20eee0a5f64f0a523093f5f1b3'
- 'a255f689d3a65187635a7dea2862b7c323c6efbc65501069bfe0cea7669d12a3')
+sha256sums=('054d2fabdf70fce0dfaeb20eed265bd7894045d3e00c3d1ddb72d1c77c339ca1'
+ '09546864a36ec83cfbedb29c97ead05778b4da370a84185565973f28f49f2880')
prepare() {
patch -d Trilinos-trilinos-release-"$_pkgver" -p1 -i ../compiler-errors.patch
@@ -34,7 +34,9 @@ build() {
-DTrilinos_ENABLE_ALL_PACKAGES:BOOL=ON \
-DTrilinos_ENABLE_PyTrilinos:BOOL=OFF \
-DTrilinos_ENABLE_Gtest:BOOL=OFF \
- -DTrilinos_ENABLE_TESTS=OFF \
+ -DTrilinos_ENABLE_TESTS:BOOL=OFF \
+ -DTrilinos_ENABLE_TrilinosFrameworkTests:BOOL=OFF \
+ -DTrilinos_ENABLE_TrilinosATDMConfigTests:BOOL=OFF \
-DTPL_ENABLE_gtest:BOOL=OFF \
-DTPL_ENABLE_MPI:BOOL=ON \
-DTPL_ENABLE_HDF5:BOOL=ON \