summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1454fc2106e5..4d94ace1ef52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
_pkgname=triton
pkgname=${_pkgname}-git
-pkgver=v0.7.r102.gfb3241e9
+pkgver=0.8.1.r266.g6b929c39
pkgrel=1
pkgdesc='Dynamic binary analysis framework'
url='https://triton.quarkslab.com/'
arch=('x86_64')
license=('Apache')
depends=('capstone' 'z3' 'python')
-makedepends=('git' 'boost')
+makedepends=('git' 'boost' 'cmake')
provides=(${_pkgname})
conflicts=(${_pkgname})
source=("$pkgname::git+https://github.com/JonathanSalwan/Triton.git")
@@ -20,7 +20,7 @@ sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname}"
- git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --tags --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {