summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c6cf16cec7c..c749b70be172 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Todd E Johnson <todd@toddejohnson.net>
pkgname=trunk-recorder-git
-pkgver=r1543.9f57d36
+pkgver=r1546.bd4975d
pkgrel=1
pkgdesc="Records calls from a Trunked Radio System (P25 & SmartNet)"
arch=(x86_64 i686 armv5 armv6h armv7h aarch64)
url="https://github.com/robotastic/trunk-recorder"
license=("GPL3")
-depends=("gnuradio" "gnuradio-osmosdr" "libuhd")
-makedepends=("git" "cmake" "boost" "cppunit")
+depends=("gnuradio" "gnuradio-osmosdr" "libuhd" "boost-libs" "sox" "fdkaac")
+makedepends=("git" "cmake" "boost")
optdepends=()
source=(${pkgname}::git+"https://github.com/robotastic/trunk-recorder.git#branch=4.0-beta"
'trunk-recorder.service'
'trunk-recorder.sysusers'
'trunk-recorder.tmpfiles')
sha256sums=('SKIP'
- '413f2090a853422b8987bdb4dfa6cbcf7d5b75dbdb1989d030e7c19d3e9dfb9b'
+ '60193b9007ae10c05f70155c909fe2882432a5771d658e733c3d3d89cf46d949'
'f2e06d333ec8a64c869a9cf369015bf6e0b9819d2af259b4d1c411ed3cca78f8'
'c20344ba366fcab3f3552e2b5e537f394406ab634f35c2b8858423ffa63fd0e8')
@@ -32,17 +32,13 @@ build() {
cmake "../${pkgname}" \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr
- make
+ make -j $(nproc)
}
package() {
cd build
- #DESTDIR="$pkgdir" make install
- install -D -m 755 "recorder" "$pkgdir/usr/bin/recorder"
- install -D -m 755 "libgnuradio-op25_repeater.so" "$pkgdir/usr/lib/libgnuradio-op25_repeater.so"
- install -D -m 755 "libunit_script.so" "$pkgdir/usr/lib/libunit_script.so"
- install -D -m 755 "libopenmhz_uploader.so" "$pkgdir/usr/lib/libopenmhz_uploader.so"
- install -D -m 755 "libbroadcastify_uploader.so" "$pkgdir/usr/lib/libbroadcastify_uploader.so"
+ make DESTDIR="$pkgdir" install
+ install -D -d -m755 "$pkgdir/etc/trunk-recorder"
install -D -m644 "../${pkgname}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -D -m644 "../trunk-recorder.service" "$pkgdir/usr/lib/systemd/system/trunk-recorder.service"
install -D -m644 "../trunk-recorder.sysusers" "$pkgdir/usr/lib/sysusers.d/trunk-recorder.conf"